Not able to Import OptionSets

Hi all,

I have been trying to import option sets, but no success. Below is the csv file ( I have a lot of Health facilities to include in the file). I do not know if I am missing something.



I am trying to import optionsets from a CSV with optionsetname, optionname and option code provided and am getting a summary showing it is created but when I check to confirm the option set is missing. I have tried importing on the Play.dhis2 same problem. Kindly assist.
I am using version 2.33.4.
My csv has these columns: [OptionSetName OptionSetUID OptionSetCode OptionName OptionUID OptionCode]

Hi @VictoriaVenda, welcome to the community and thank you for reaching out.

@dhis2-platform Confirmed. I tried to use the import app for optionsets in 2.33.8 and 2.35.3 and it didn’t work whereas it worked on 2.36.0 in

2.33.8 gave me this error:

2.34.4 gave no error but didn’t import the optionset:

2.36.0 worked well and imported the optionset:

Hi @Gassim,

What might be the problem with my file since I am unable to import? Am I missing something?


Hi @dmbantu,
Thanks for reaching out. It seems like you’re not the only user to experience this issue. Would you like to try importing in version 2.36.0

Currently reviewing the issues in Jira to see if an issue about this has been created.