Map app can't work for two filter on event map

I have add two filter on a event map . but system said “You don’t have access to this layer data”.
while It can work for any one of the two filter be setted seperately.

the file like name contain ‘??’

in dhis2: 2.37

update: filter in this post worked when using it on a data element once, but as explained in the following posts, if filter is used twice on the same data element, it doesn’t work!

Hi @linxd,

Thank you for your post! Please try to clear the cache and try again. I tried to use two filters in an event map on 2.37.5 and it’s working so please share steps to reproduce.

Here’s the favorite I used in play,

Before filter


After filter

can set the relation of two filter? and / or ?
two filter for same DE is not surport.

1 Like

Yes, you are right! I now tried to use filter for two data elements and it didn’t work! In the example above I tried to make the filter for age: Age > 70 && Age < 10, and I got the same error as yours.

The request being sent shows an error in: dimension=qrur9Dvnyt5:GT:70;LT:10 and the error is:

"httpStatus": "Conflict",
"httpStatusCode": 409,
"status": "ERROR",
"message": "Query item or filter is invalid: `qrur9Dvnyt5:GT:70;LT:10`",
"errorCode": "E7222"

@linxd, would you like to create a Jira bug issue in using your username? I will follow up on this with the developers! Thanks! :+1:

I created a Jira bug issue on your behalf: You can vote / watch as well as your comments. It might be helpful if you add a comment with your use case. Thanks! :+1: