Language/translations issues in 2.34?

Are others having issues on 2.34 with translations? The database is set to French but when I’m logged in as the admin (I use English), it looks fine. But when I log in as one of the local users (interface set to French), a lot of things are showing up in English with weird syntax - underscores, etc. Particularly in the tracker profile. Previously all of that was showing up correctly in French.

Screen Shot 2020-08-24 at 11.50.06 AM
Screen Shot 2020-08-24 at 11.50.23 AM
Screen Shot 2020-08-24 at 11.50.47 AM

Maybe suggesting the obvious here but have you tried using an incognito window to eliminate a possible client side cache issue? If it looks fine in incognito then clearing the browser cache may help. Would only likely apply after an upgrade though.

I always need and appreciate the obvious solutions, which are often my issue! In this case I logged in as an end user with incognito mode after running analytics. If others are not having this issue (particularly in non-English databases) then I will assume it’s something with ours and not a bug… It’s also only in the browser, not the android app.

I’d love to be able to answer - we run French / English on instances this side but we tend to hold back one major version at least until 6 months have passed since official release so we’re on 2.32.5 with no issues like that.
If I have a gap to spin one up in docker in my spare time I’ll let you know.
Any oddities in the log?
What about the browser dev console (F12 - network tab)?

Hello Natalie,

I am facing the same issue but with spanish language. I have implemented the COVID19 package on one of our test servers using the 2.34.1 version and build 6024645.
As you can see, I am having the same result, with some english underscore terms appearing.



I 'm not sure if it is something I have missconfigured.

Thanks for updating on this. I was able to replicate it in the play site by changing the system settings and the user language settings (not sure if both are necessary to observe the problem) so I created a JIRA issue here, feel free to comment!

1 Like

We seem to be having a similar issue on 2.33.5 in the report application
Actually there are a bunch of things that are not yet translated it seems. I don’t know whether that’s just down to the development progress… will double check with an older version to see if it’s regression or not.

1 Like