Java 8 or Java 11?

I see the documentation still recommends Java 8 or higher. Has this changed? How extensively has JRE 11 been tested? I’d prefer to move to the latest LTS but wanted to hear if there were any known issues. I came across one topic that seemed to indicate there may be an issue with some things on 11.
Thanks!