Issues by importing event from a CSV File

Hello Guys,

I Think I definitely need some helps.

I was importing some events from a CSV file by following the order of column as shown out in the DHIS2 guide. The first column should be “event” but it’s not required, in my CSV file I left it empty and I got this following message. Please can you help me. My DHIS2 version is 2.34.9.

This is my excel file format


If possible please upgrade to one of the latest and supported versions. :pray:

It would be interesting to test this in any of the instances and see if we can reproduce the issue and figure out why this issue is happening either it’s a bug or a configuration issue.


I am having the exact same problem. I tried with and without an Event ID but receive an error message in any case. I am wondering whether a column is missing.
In any case any advice on this will be really appreciated.
I also tried with the BIF-app and Data Import Wizard but also failed with those tools.

1 Like

Thank you @George_McGuire! Would you by any chance be able to share the steps to reproduce the issue on any of the instances? If not, it’d be helpful to know what the error message (is it the same as the one in the screenshot posted by @krendel1811?)

Could you check and compare with the columns in the template in CSV-Events-payload-template from the docs?


Hi Gassim
Thanks a lot for trying to help. As I used the exported CSV-file for importing I do not see how this file format can be incorrect.

I explored exporting and importing in DHIS 2 Demo - Sierra Leone but even for “overwriting” the same event DHIS2 just shows “in progress” without ending or showing an error message

This is the file format used for exporting and importing

But here the problem is that I do not understand that complex Tracker Program and cannot even identify the TEI for checking.

Concerning import file format, not easy to find the pertinent reference in the extensive DHIS2 documentation (also because I am not a developer and do not understand what API-endpoints are) but I assume it is this table:

I compared this table with the CSV-files exported in DHIS2 2.40 snapshot (which I am mainly using) and found that the column headers and the order of columns are identical. I reconfirmed in 2.40.1-SNAPSHOT that:

  • exporting an event, changing only the value and re-importing works every time without error and instantly
  • using the same file but trying to upload a new Event (with or without EventID) fails every time with the same error Mr. Kenold got:
    Event.trackedEntityInstance does not point to a valid tracked entity instance: null

My best guess is that this is a bug or there is a setting which prevents uploading new events.

Thanks for the detailed response!

Please avoid using SNAPSHOT because it’s not a stable release you might even encounter other issues which might probably not happen in the stable version.

Hi, I tried the same on the Play instance using 2.39. In this case I do not receive an error but the upload remains in status “In progress” and does not complete.

Hey @George_McGuire!

Did you find a work around? I have worked unbelievably hard to upload event data and this showed some promise but alas, It doesn’t complete the job.

@Gassim Do you mind helping. I have failed with bulk upload through Bulk Load and now Import/Export because of bugs. This is very frustrating

Hi Lilian
I abandoned this approach but successfully using Bulk-Load app for uploading Event data.

Hi @lillian1n2

Are you facing an event program issue or a tracker program issue. There’s a known bug for importing events ([DHIS2-12345] - Jira) and it will be available in the next releases, is this the same issue you’re encountering? i.e. not completing the job (does it load indefinitely?)

If it’s not exactly the same as the issue described above in the first post, then you’re welcome to create a new topic post with details of the errors you are seeing. Thanks!