Is it possible to run the dhis2 docker with just docker engine and the compose plugin?

I’m trying to get a quick linux instance up on an ec2. I installed docker engine and the compose plugin but get a docker-compose not found (it’s “docker compose” on the ec2). I tried also with docker engine and then installing docker-compose which kind of worked as everything spun up (3 containers nginx, tomcat, and db) however from what i can tell the database doesn’t get seeded properly. I see the seire leone when logging in and can browse various pages but don’t see any data like the demo servers i’ve tested online.

Any thoughts on this (I plan to use this for dev purposes, not prod as it doesn’t seem to be suggested)

this is my userdata:

sudo apt-get update

sudo apt-get remove docker docker-engine -y

sudo apt install -y

sudo systemctl start docker

sudo systemctl enable docker

install docker-compose

sudo curl -L “$(uname -s)-$(uname -m)” -o /usr/local/bin/docker-compose

sudo chmod +x /usr/local/bin/docker-compose

install node 14.x / npm

sudo curl -sL | sudo bash -

sudo apt install nodejs -y

install yarn

sudo npm install --global yarn

install d2 cli

sudo yarn global add @dhis2/cli

sudo echo ‘export PATH=“$HOME/.yarn/bin:$PATH”’ >> ~/.bashrc

sudo source ~/.bashrc

stand up cluster

sudo d2 cluster up --db-version 2.39 --seed

This might be a cache issue, please use the Data Administration app (Maintenance) and select Clear Application Cache and Reload apps. Additionally, try again using your browser’s Guest Mode

Additionally, please check if there are any errors in the Catalina.out log. Thanks!

Thanks, will take a look at that.

I tried clearing the cache, and reloading the apps as suggested but didn’t seem to make a difference (also guest mode and incognito). I stumbled on this screen so think the data is there. If your familiar does it seem to align with seed data? For the catalina logs is it just to go into the tomcat docker container for those or are they available via the UI?

It seems the data is there, yes. Could you try restart the instance?


I restarted the instance but didn’t seem to help. You mentioned the catalina.out log. should i just go into the container for that? Are they any other logs i can reference? Thanks!