Installing DHIS2 Doker in Mac OS

Dear colleagues,
I need urgently a detailed guide for installing in local dhis2 Doker in Mac Mac book pro, Mojave system).
Thanks a lot in advance for any help

Hi @ToufikHossain. As you mentioned MacOS Mojave, you should have an intel-based Mac, which means you can follow our documentation to set up a local instance.

In our documentation we guide you, step by step, how to install the CLI and install a container: Prerequisites and initial setup | DHIS2 Developer Portal

We also have a blogpost going into more detail on top of that here: DHIS2 with Docker | DHIS2 Developer Portal

One of the prerequisites is installing Docker, you can do this from the Docker website, and their website should be able to guide you how to install it. Get Docker | Docker Documentation

If you run into any issues, do let me know!

1 Like

Our project may be of some assistance @ToufikHossainGitHub - baosystems/docker-dhis2: DHIS2 on Tomcat

Download docker-compose.yml to your system, and run the commands at the link above, like docker compose up -d, and you’ll have DHIS2 with version 2.38.1.1 running in a few minutes.

Dear Alan, First thanks a lot for your kind help,

In fact, For days and days I am trying installing a Doker in Windows but I was not able to do so. The reason maybe is I have windows in Parallels VM on Mac OS. I try then to install a DHIS2 Doker in Mac. I tried all the method mentioned in the Guide but I am still unable to install Yarn your proposal for help come to me in the very right moment.

I applied exactly your procedure but I get nothing.

Exemple : I download "docker-compose.yml. » W en I open it, there is nothing to be downloaded just open a programing page with 149 lines. I didn’t know what I should do with all these lines.

After I run "GitHub - baosystems/docker-dhis2: DHIS2 on Tomcat » in Terminal then I get this message :

"Last login: Thu Aug 25 16:52:24 on ttys000
iMac-de-Abdalla:~ abdallatoufikhossain$ https://github.com/baosystems/docker-dhis2/blob/main/docker-compose.yml
-bash: https://github.com/baosystems/docker-dhis2/blob/main/docker-compose.yml: No such file or directory
iMac-de-Abdalla:~ abdallatoufikhossain$

I repeat again and again the same operations as expected I get the same results.

The problem is I am not a developer just a user trying to develop a tracker in DHIS2. I achieved the fundamental course and now should work on developing the tracker (I have all the needed materials already prepared in excel to be used once I succeed installing Doker.

I would be grateful then if you could explain to me in detail step by step how can install the Doker.
Abdalla

Thanks again and again for your precious help
Abdalla

Dear Rene,

First of all thanks a lot for your prompt and helpful response.

I succeeded to install the Doker program but failed to install Yarn despite the fact I tried to apply all installing methods suggested in the « Presquisites and initial setup » chapter.

  1. npm packages : I didn’t know which package should I install « Front-end » or « Back-end ». I tried the front-end one but I get nothing;

  2. Homebrew Package and run Terminal to install yarn. Nothing installed;

  3. « MacPorts » and "sudo port install yarn ». As the previous methods nothing installed.

My impression is all this methods necessite an IT skills beyond my capacity as a simple user trying to develop a tracker program.

I would be very thanks to you if you could help me achieve this installation and start working in my project.

Thanks again and again for your help
Abdalla

Dear Rene Pot and Alan Ivry,
Thanks to your precious help and advice, I have just successes in installing DHIS2 37.0. But instating installing in my iMac a local version I installed the web version. I do not know how but this is what happens. The problem was ‘Yarn’ for which I am forced to install it manually.

(After more than 2 weeks trying to install it on Windows 10 I just came to understand by the end that we can’t install VM over another VM. My Windows 10 run on Parallels desktop which also a virtual machine)

I have a question please how can I upgrade to 38.1.1 version? I would be grateful if one of you could explain who I can do it before start working in my tracker project.

Thanks again and again for your prompt and precious help.
Kind regards for you both
Abdalla

Good morning dear Alan,
Last night I have partially succeeded to install a local dhis2 2.37.0. but it completely empty added to that I am unable to create a data element or organization unit in it. There is something wrong unable to identify.
I am very interested in the methods you have kindly suggested yesterday. I would be grateful if you could, as I mention in my last message, to indicate step by step how could I apply it?

Thanks again and again for your kind help
Abdalla