Importing OrgUnits into DHIS2

Dear DHIS2 Community,

I am having trouble importing orgunits into DHIS2. I imported the csv (with about 26,000 orguits) but the data is not being reflected into DHIS2. I tried to manually created one of the orgunit and got an error that it is a duplicate. What could be the issue?

Have you tried going to “Maintenance” > “Organisation Units” and verifying they are not showing up there? Did you get an error message while importing?

You screenshot shows that there is already another Organisation Unit with that code.

Via the API you could also see the Organisation Units and the amount of them via the url :

Hello Jaime

I have tried checking trough maintenance and they are not showing up there. I did not get any error message while importing the organisation unit.

The codes are specific to the particular organization unit which led me to believe that they could have been imported but are not displaying on the front end.

Can you try importing again and verifying the logs?