Hiding datasets from dhis2 tracker app(or even better preventing it from syncing to the app)

I have just syncronized dhis2 tracker app with dhis2. I’m interested only with tracker program but I see other datasets also getting syncronized.
What I have tried:

  • Created a test user with group tracker admins
  • Limited sharing options for the program, program stages, dataelements and optionsets to the group
  • Created a role and assigned to the test user

For the experiment I ensured one of the datasets has sharing option assigned to a different group from the one assigned to the program. Still it shows in the app.
I’m still getting other datasets showing/synced in the tracker app. How can I achieve limiting it only to the tracker program?

Hello, @salad_guyo

This is probably happening because the datasets you are seeing in the device are publicly shared. Please make sure you remove that sharing setting and perform a sync for them to disappear.

Hi @jaime.bosque,
I tried exactly that by ensuring two of the datasets only has sharing settings x that is not related with everything related to the tracker program. The datasets still shows on the app.

Hello @salad_guyo . Are you sure that those datasets are not publicly shared ? For example, this dataset will always be shown in the Android device as they are publicly avaialble to any user

1 Like

Thanks @jaime.bosque I did that but the dataset still show,
I have set both Metadata and Data to No access for the datasets.
I have assigned the user to a group that I have included only to the sharing settings for the program.

I have even uninstalled and reinstalled the app just so that cache does affect the result.

If I get it right the screenshots are

  1. For the tracker
  2. For the dataset

The dataset “Advanced HIV Disease (AHD) Report” is still being shown in the Android App, is that correct? If yes, can you make sure that the user that is using the Android device is not part of the Data Entry group?

Is this a testing server and you could share credentials with me via private message?


Exactly @jaime.bosque,
The user I’m using for the tracker app does not have Data Entry group nor do the Program and other related metadata.
Sorry I’m afraid I can’t coz the test instance was restored sensitive data from our production instance.

Much thanks @jaime.bosque,
I was making a horrible mistake of giving user super user role by (checking ALL box) under system section when creating user role.
I ensured the sharing settings are correct for Program, Program stages, Data elements, Optionsets, Tracked entity type and Tracked entity attributes.
Also, giving public access to datasets will make it available to the tracker - revoke public access and assign the desired group.
As desired, now I have the dhis2 app showing only tracker program. :slightly_smiling_face:


Perfect, good to read this, @salad_guyo