Generating resource and analytics tables

Hi All,

For some time now, when I run the analytics, without skipping the event, the process does not end and I even tried to do it through the API, still not a good result. While there are data of events that are important to me for the analyzes.

Is there a bug in DHIS2 or how? because this problem is very long

By API: the message is

[{
		"uid": "MwVUyUaDggr",
		"level": "INFO",
		"category": "ANALYTICS_TABLE",
		"time": "2019-07-03T09:41:42.020",
		"message": "Updating resource tables",
		"completed": false
	}, {
		"uid": "tkQHTVCmJo7",
		"level": "INFO",
		"category": "ANALYTICS_TABLE",
		"time": "2019-07-03T09:41:42.019",
		"message": "Analytics table update process started",
		"completed": false
	}
]

But by DHIS2 Front-end the process does not stop

Regards

1 Like

Hi @Carlos_Nyembwe,

How long have you let the process run without the process completing? Depending on the amount of data you have in your database, this process can be very time-consuming.

If you run analytics for only a small portion of the data, will it finish?

1 Like

Hi Stian,

Look at the screen after analytcs in our server on 2.30 with Tracker in

1 Like

Hi again @Carlos_Nyembwe,

based on the image you provided, it seems like the issue with the process not finishing is in the app. In fact, most likely the process is running and completing on the server, but its not being reflected in the app.

Based on the error message, it appears to be some form of connection error. Could you expand the error message and write it here?

I will also ask if @dhis2-apps has information about what the issue related to the app might be.

1 Like