Forbidden access on DHIS2 next-gen server setup

Dear colleagues,

I am seeking your assistance on setting up an instance using the DHIS2 next-gen approach.
I have followed all the steps as provided by @bobj (in the recorded/shared video) and all went successful, however, when I try browsing the DHIS2 instance, this is what appears on web. I also, tried searching for solution but all in vain.


Any support, idea, … is welcomed.


1 Like

Hi @Josue,

Have you seen the guide here: GitHub - bobjolliffe/dhis2-tools-ng: Next generation dhis2-tools It might help to review the steps and configuration. The error you shared above “You don’t have permission to access this resource.” is usually related to not giving the proper access or naming to files or folders please check.

To get further support please share more info about the environment with versions of the software…etc When you see this error are you visiting https://<server_name> or https://<server_name>/<instance_name> ?

Please share as much info as possible to be able to debug and understand the cause of the issue since the error posted above is generic there are so many issues that could cause it.


Hi @Gassim,

Apology for a late reply. Successfully, I have managed installing the DHIS2 instance using next-gen approach after your comment. I realized that I used the IP address instead of the FQDN in the …/containers.json file and that’s when I could get the ‘Forbidden Access error’ while trying to browse https://<server_name or FQDN> or https://<server_name or FQDN>/<instance_name>

I reviewed the guide on the Github, a couple of times and changed that configuration, thereafter, everything run successfully.

I am/was trying this DHIS2 next-gen approach on Ubuntu 20.0.4, and running DHIS2 2.36.8.

Thanks for guidance.



Thank you for sharing @Josue! :slight_smile: Glad you fixed it :+1::+1:

1 Like