[FIXED] [Line Listing app - v100.0.0 / DHIS2v2.38] Error displaying data

Yes, facing the same issue, tried downloading the table layout option with CSV || XLS and both come out blank, the Plain Data Source Option only give out the first 100 records.
@Gassim please help with this urgent issue. Does downgrading the war file back to 2.37 work? Maybe this issue is not present in that version? Would this require any changes to the Database?

1 Like

Hi @ifeanyiokoye

Yes I see the same behaviour and am following up with the devs now.


To downgrade you will need your backup on 2.37; which can be a problem if you have new data in your 2.38 copy. There is not really a great way to downgrade an existing DB to an older version unfortunately.


Thank you @Shurajit_Dutta, I guesss Ill just have to wait for a fix, hopefully it will be resolved soon.

1 Like

@ifeanyiokoye @WaluQ ,

I have found a workaround to download the csv files.

Follow the below steps:

  • Open the line listing app and load the table you need to export
  • Open Developer tools in the browser
  • Go to the network tab
  • Now click on download in the UI and select the format you want to download.
  • The file will be downloaded (empty file) but you will see a new entry in the network tab.
    Ex: https://play.dhis2.org/
  • Copy this request and replace paging=false with pageSize=100000 (Some arbitrary number that would include all the results)
  • Paste this URL back in browser and the file will get downloaded with all the records.

@Shurajit_Dutta , if it helps, the issue is with paging. paging=false is not working as expected in the API.



@ifeanyiokoye @WaluQ @rithvik thanks for your inputs

It seems if you download it as a plain data source rather then a table layout it should also work. It worked for me, can you verify on your end?

The devs are working on a fix as well for the table layout download.


1 Like

It works but is limited to 100 records when you use the event reports app. The linelisting app gives more

1 Like

Yes, only the first 100 records are dowlaoded. For now we’ll depend on @rithvik’s workaround, though it might not be very userfriendly for field staff. @Shurajit_Dutta, do we need to create a bug report for this?

Hi @ifeanyiokoye @WaluQ I am able to get much more then 100 records. In any case, you can test the fix here by trying to download this as a table layout or plain data source, should download the whole thing : DHIS 2 Demo - Sierra Leone

Login is admin/district

So should see the fix in the next patch release hopefully

For some reason, I still get only the first 100 rows even on Demo.

Hi @Shurajit_Dutta, any update from Dev on the fix?

Tried this and it works.

1 Like

Dear @Shurraj and Dev Team,

I am facing the same problem with downloading more than 100 records. Is there a fix to this issue?


1 Like

Hi @Amza

What version of dhis2 are you using? This issue has been fixed, see here: [DHIS2-13606] - Jira