financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

···

Sent from Outlook

A little more information here:

In the database, I found that in the analytic tables the financialoct field was blank. Where its working I see that that field is set to '2013Oct’ or whatever year. Do I need to configured something so that these analytic tables are generated right?

image

image

···

From: Dhis2-users dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net on behalf of Adam Preston adam704a@hotmail.com

Sent: Wednesday, October 4, 2017 3:14 PM

To: dhis2-users@lists.launchpad.net

Subject: [Dhis2-users] financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

Sent from Outlook

Hi Adam,

that is strange. Which version of DHIS 2 are you running?

Also, could you have a loo in table _periodstructure and see how those quarters are linked to the financial year (see the column headers which are equal to analytics tables) ?

regards,

Lars

image

image

···

On Thu, Oct 5, 2017 at 1:16 AM, Adam Preston adam704a@hotmail.com wrote:

A little more information here:

In the database, I found that in the analytic tables the financialoct field was blank. Where its working I see that that field is set to '2013Oct’ or whatever year. Do I need to configured something so that these analytic tables are generated right?

Sent from Outlook


From: Dhis2-users dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net on behalf of Adam Preston adam704a@hotmail.com

Sent: Wednesday, October 4, 2017 3:14 PM

To: dhis2-users@lists.launchpad.net

Subject: [Dhis2-users] financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

Sent from Outlook


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org

I am running 2.27

The _peroidstructure table seems fine to me.

Again, it just sees like some records just aren’t being generated for the analytic tables. Where it’s working I get two records, one for the financial year one for the annual year.

Where it’s not working I only get the entry for the annual year.

Any help here would be really appreciated.

-Adam

image

image

···

From: Lars Helge Øverland lars@dhis2.org

Sent: Thursday, October 5, 2017 3:05 AM

To: Adam Preston

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

Hi Adam,

that is strange. Which version of DHIS 2 are you running?

Also, could you have a loo in table _periodstructure and see how those quarters are linked to the financial year (see the column headers which are equal to analytics tables) ?

regards,

Lars

On Thu, Oct 5, 2017 at 1:16 AM, Adam Preston
adam704a@hotmail.com wrote:

A little more information here:

In the database, I found that in the analytic tables the financialoct field was blank. Where its working I see that that field is set to '2013Oct’ or whatever year. Do I need to configured something so that these analytic tables are generated right?

Sent from Outlook

From: Dhis2-users <dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net > on behalf of Adam Preston adam704a@hotmail.com

Sent: Wednesday, October 4, 2017 3:14 PM

To: dhis2-users@lists.launchpad.net

Subject: [Dhis2-users] financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

Sent from Outlook


Mailing list:
https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe :
https://launchpad.net/~dhis2-users

More help :
https://help.launchpad.net/ListHelp


Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org


I just tried again with 2.28…same thing.

One other note, the data element I am having a problem with is entered on an annual basis and I am wanting to report this on a FY (starting October) basis. I feel like this has something to do with it.

image

image

···

From: Dhis2-users dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net on behalf of Adam Preston adam704a@hotmail.com

Sent: Thursday, October 12, 2017 12:16 PM

To: Lars Helge Øverland

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

I am running 2.27

The _peroidstructure table seems fine to me.

Again, it just sees like some records just aren’t being generated for the analytic tables. Where it’s working I get two records, one for the financial year one for the annual year.

Where it’s not working I only get the entry for the annual year.

Any help here would be really appreciated.

-Adam

Sent from Outlook


From: Lars Helge Øverland lars@dhis2.org

Sent: Thursday, October 5, 2017 3:05 AM

To: Adam Preston

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

Hi Adam,

that is strange. Which version of DHIS 2 are you running?

Also, could you have a loo in table _periodstructure and see how those quarters are linked to the financial year (see the column headers which are equal to analytics tables) ?

regards,

Lars

On Thu, Oct 5, 2017 at 1:16 AM, Adam Preston
adam704a@hotmail.com wrote:

A little more information here:

In the database, I found that in the analytic tables the financialoct field was blank. Where its working I see that that field is set to '2013Oct’ or whatever year. Do I need to configured something so that these analytic tables are generated right?

Sent from Outlook

From: Dhis2-users <dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net > on behalf of Adam Preston adam704a@hotmail.com

Sent: Wednesday, October 4, 2017 3:14 PM

To: dhis2-users@lists.launchpad.net

Subject: [Dhis2-users] financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

Sent from Outlook


Mailing list:
https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe :
https://launchpad.net/~dhis2-users

More help :
https://help.launchpad.net/ListHelp


Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org


Never mind. I’m an idiot.

Turns out I wasn’t loading in the FY data.

image

image

···

From: Dhis2-users dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net on behalf of Adam Preston adam704a@hotmail.com

Sent: Thursday, October 12, 2017 3:59 PM

To: Lars Helge Øverland

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

I just tried again with 2.28…same thing.

One other note, the data element I am having a problem with is entered on an annual basis and I am wanting to report this on a FY (starting October) basis. I feel like this has something to do with it.

Sent from Outlook


From: Dhis2-users dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net on behalf of Adam Preston adam704a@hotmail.com

Sent: Thursday, October 12, 2017 12:16 PM

To: Lars Helge Øverland

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

I am running 2.27

The _peroidstructure table seems fine to me.

Again, it just sees like some records just aren’t being generated for the analytic tables. Where it’s working I get two records, one for the financial year one for the annual year.

Where it’s not working I only get the entry for the annual year.

Any help here would be really appreciated.

-Adam

Sent from Outlook


From: Lars Helge Øverland lars@dhis2.org

Sent: Thursday, October 5, 2017 3:05 AM

To: Adam Preston

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] financial year reporting

Hi Adam,

that is strange. Which version of DHIS 2 are you running?

Also, could you have a loo in table _periodstructure and see how those quarters are linked to the financial year (see the column headers which are equal to analytics tables) ?

regards,

Lars

On Thu, Oct 5, 2017 at 1:16 AM, Adam Preston
adam704a@hotmail.com wrote:

A little more information here:

In the database, I found that in the analytic tables the financialoct field was blank. Where its working I see that that field is set to '2013Oct’ or whatever year. Do I need to configured something so that these analytic tables are generated right?

Sent from Outlook

From: Dhis2-users <dhis2-users-bounces+adam704a=hotmail.com@lists.launchpad.net > on behalf of Adam Preston adam704a@hotmail.com

Sent: Wednesday, October 4, 2017 3:14 PM

To: dhis2-users@lists.launchpad.net

Subject: [Dhis2-users] financial year reporting

Hi

I am seeing some unexpected results when running reports using the financial year period. When running a regular quarterly report everything looks fine

but when running the same report but with the financial year (start october) period the data is missing.

I have rebuilt the analytics tables (and cleared my cache) a few times, and it’s still the same. Are there any tricks to get this working? Or am I doing something wrong?

Sent from Outlook


Mailing list:
https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe :
https://launchpad.net/~dhis2-users

More help :
https://help.launchpad.net/ListHelp


Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org


1 Like

Hi Adam,

does the "Total births" data element has an average aggregation type? If
so, I just provided a fix in master and 2.28, and I recommend that you
upgrade and try again.

best,

Lars

···

--
Lars Helge Øverland
Lead developer, DHIS 2
University of Oslo
Skype: larshelgeoverland
lars@dhis2.org
http://www.dhis2.org <https://www.dhis2.org/>

Hello Adam

I seem to have similar issues as you reported but in my case, I have imported the FinancialOct 2018 into DHIS2 2.29 but the data doesn’t show in PIVOT or dataset report. How did you overcome your challenge?

Thanks.