Events showed in statistics but Analitic tables says "No events exist, not updating event analytics tables "

Dear,

I have a strange issue, the event are created via API they got 200 as answers, I can see the event in the database, and if I go in “Data administration” > “data statistics” I see the events:

I run the Analytic table “export” in “Data administration” > “Analytic table” I see that the tool don’t find any event;

I looked on the code and I found the message dhis2-core/AbstractEventJdbcTableManager.java at 69436a1353fdf3ff56f92bc9671cdb98696643bd · dhis2/dhis2-core · GitHub,
EDIT: When I execute this SQL; I execute

select programstageinstanceid from programstageinstance where eventdatavalues is NOT NULL limit 1;

I got a result but this

select programstageinstanceid from programstageinstance where eventdatavalues != '{}' limit 1;

it gave no result

Does anyone have an idea why this happen ? Is it an compatibility issue with PostGres 11 ?

I am really annoyed because I cannot make a report on my 1.7 million events pushed (it took days to push them)

DHIS2.35.2, TOMCAT 8.5, POSTGRES 11 on windows server 2019

Thanks in advance

From my internet search POSTGRES interpret ‘{}’ as an empty literal array but the column is BIGINT so I wonder how it can be an array.

Even if I didn’t find the confirmation, I suspect that POSGRESQL is looking for not empty arrays which cannot happen in a BIGINT column …

solved without knowing why …