Error when trying to create a relationship

Hi All,
This one has me really confused. I’m trying to create a relationship between two TEIs. This works for other TEIs, but when trying to save this relationship, it just freezes (you cannot press save). If you look at the browser messages, its throwing a 409 error

“Relationship qSbGhEIW1xr already exists”

But when I use identifiableObjects to try to find that UID, nothing is returned.

identifiableObject with id qSbGhEIW1xr could not be found.

Similarly, when I look at the tei data, relationships is empty (there are no existing relationships).

Any ideas would be appreciated

Hi @kstankevitz

What version of DHIS2 are you using? Please did you try Maintenance - clear the application cache and reload apps in the Data Administration app, and then login using your browser’s Guest mode (Browse Chrome as a guest - Computer - Google Chrome Help) to check there’s no cache issue. Also, what do you see if you go to yourInstance/api/tracker/relationships?tei=UID?

Hope we find out what’s going on. Thanks!

Hi @Gassim - I’m on 2.39. I tried a number of items in data administration - deleting soft deleted values (maybe there was a relationship at one time?), clearing application app, reloading apps. I also tried in incognito mode. Nothing has worked yet.

1 Like

Sorry to hear that… I’m wondering if we could reproduce this on the play instance as it will be so much easier to figure out the issue… Does this happen only for one TEI or all TEIs? In one program or all programs?

Please did you give this option a try?