Error when opening Tracker capture

Hi Devs

I’m receiving this error in the browser console when attempting to open the tracker capture page

:9090/dhis/api/27/userDataStore/gridColumns/trackerCaptureGridColumns:1 Failed to load resource: the server responded with a status of 404 (Not Found)

Attached is a screen shot of the full console log.

Has anyone experienced this issue and if you able please can you direct me in how to solve this?

image

Version:
2.27
Build revision:
bd3a0ff

Kind regards

Pooben

This message and any attachments are subject to a disclaimer published at http://www.hisp.org/policies.html#comms_disclaimer. Please read the disclaimer before opening any attachment or taking any other action in terms of this electronic transmission. If you cannot access the disclaimer, kindly send an email to disclaimer@hisp.org and a copy will be provided to you. By replying to this e-mail or opening any attachment you agree to be bound by the provisions of the disclaimer.

Hi Pooben,

you can safely ignore this.

This is an entry in the user data store we use to store the user specific layout of the tracker dashboard. When no layout is set, this request will return a 404.

regards,

Lars

image

···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org

Hi,

Like Lars is saying, this error can be safely ignored. I have pushed an update to 2.27 and 2.28 that sets userDataStore/gridColumns/trackerCaptureGridColumns to null if it is not found.

This way you should only get the error once and next time you load the page the userDataStore/gridColumns/trackerCaptureGridColumns exists (but null) and will therefor not throw a 404 error.

Best regard,

  • Lukas Wijgaart van Dijk
···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org