Error on data import - A valid dataset is required

We use a CSV import process every quarter to import aggregate data for some countries. We recently upgraded to, and the Import/Export app no longer seems to be accepting our CSVs.

We follow the csv format detailed in the documentation, Data - DHIS2 Documentation

specifically: dataElement, period, orgUnit, cocuid, aocuid, value

We are now getting an error:

I’ve tried adding a dataSet column at the beginning and end and neither of these have worked… can anyone confirm the required CSV format?

The format is correct
DE_uid, period_id, org_uid, categoryoptioncombouid, attributeoptioncomboid, value

Kindly ensure that the dataset period type is the matching with the period id

It is.

This is the format.

deuid period cocuid AOC uid Value
ab7wQUqXJF2 202212 njNNRBX3ATN aGe7OmrDrk9 nrivIU1hS7F 1

I’ve figured it out…If you have “require data elements to be part of data Set" checked, you are unable to import any data, regardless of if the data elements you’re trying to populate are in data sets. I think this is a bug. I’ve documented it in Jira."require%20data%20elements%20to%20be%20part%20of%20data%20set"


Hi @kstankevitz

Thank you for the clarification! Could you please create a new jira issue because the one you commented on is ‘closed’ by the person who created it?

sure… here is the new issue [DHIS2-14693] - Jira


@kstankevitz. Many thanks for the bug report. We’re discussing this internally and will work on fixing. We’re seeing a bit of confusion around the “require data elements to be part of data set” property, so let us know if you enabled this on purpose and if you would expect it to function differently.

1 Like

Hi @tzemp - I think the use case being discussed on Jira makes sense for how we would use this feature - “prevent accidentally importing data for a data element that is no longer used and therefore no longer assigned to any data set”


But now that I think about it… this might actually be the default behavior… I’m not sure if it would let you import data for a DE that is not in a dataset, given that it wouldn’t be able to identify the relevant periods or AOCs for the DE…

1 Like

Hello. Is there any progress on resolving this?

I have been attempting data uploads to no avail.

Bulk Load app, Data Import Wizard, and Import/Export app all have the same issues.

Is there anything I could check with permissions or anything?

HI @lillian1n2

The Jira bug issue you created got fixed ( for these versions: 2.41,2.40.0,2.39.2,2.38.4,2.37.10

What version of dhis2 are you using please?


Oh I’m using v