Error message when intall app bulk load

Hi, please i would like to install bulk load, here is the error that i get:

Here is the error in red above:

Failed to install app: Processing of multipart/form-data request failed. /home/dhis/tomcat-dhis/work/Catalina/localhost/ROOT/upload_bdb8f169_44a3_49ed_ae9a_76a80be552b3_00000000.tmp

Any idea on how to solve it please @eyeseetea EyeSeeTea, @Stephan_Mestach @Gassim
Thank you

Looks like here are the server versions supported by the bulk upload app:
Screenshot from 2024-06-14 10-47-25

Is your server version within this range?

Also @eyeseetea can talk more to this.

1 Like


Thanks @Quoda, @Ornella I’ve shared it with my colleagues to see if they can help. Will let you know ASAP. Thanks!

@Quoda you may me right, i use Version 2.40.3


Just tested in dhis2 play instance v40.3 and it installed fine without any error.

You can download latest release from here Releases · EyeSeeTea/Bulk-Load · GitHub

Can you install other apps in your instance? Can you also check sharing settings in the system for that folder if Tomcat user does have write access to it.

1 Like

@Daler I try to install another app, still giving me the same error. Please can you show where to find the sharing setting in the system?

1 Like

By looking at the error message seems like you got installed dhis2 in *.unix environment.

Have a look at this article and see if you followed along. You should have dhis2 user in your instance and that particular user should have access to the folders, read/write:

About how to set permissions for folders in *.unix environments, follow this:

1 Like

it points more either

  • a corrupted zip
  • to a access right problem : the file is uploaded to /home/dhis/tomcat-dhis/work/Catalina/localhost/ROOT/
  • or a disk full

why don’t you have it installed through the “App hub” directly instead of installing it manually ?

1 Like

@Stephan_Mestach in the App-Hub i do not see it

1 Like

Just a note: As Clement noted above, the Bulk Load app is indicated as having a maximum DHIS2 server version of v38. When using a v40 instance, it should not be available from the app hub.

1 Like

I solved it, thank you guys. The problem was the permission to the path /home/dhis/tomcat-dhis/work/Catalina/localhost/ROOT/.


Awesome! Thanks for letting us know!