Error login

Dear community,
do you know what is this problem?

how to solve it?
thank you
channara

Hi @Channara,

This error is usually displayed whenever you are not connected to the Internet and there is no previous login registered on the App. As you know the Android supports offline mode but the initial connections must be made while online so the user is verified and all the metadata/data synced.

Please, make sure your phone is connected and try again.

HI @jaime.bosque,
Ahh,thank your answer,
one more thing, how can we make offline entry for TEI?

thanks
channara

Hi @Channara.

You can make offline entry of TEI, events, datasets after the fist log in. I am not really sure I am understanding your question…

Are you aware of the official documentation: https://docs.dhis2.org/2.34/en/dhis2_android_implementation_guideline/dhis-2-capture-android-overview.html ? There you can see all these capabilities.

Best.

Hi @jaime.bosque,
I use tracker capture for individual record.
usually, dataset is available offline, but TEI need to search before create new.

thanks
channara

Yes, this is the expected behavior. You must perform a search before introducing any TEI; this was designed like this to avoid duplicates.

It is explained in the documentation: https://docs.dhis2.org/2.34/en/dhis2_android_capture_app/programs.html#reset-search-fields

Regards.

1 Like

But I have enough data on my android phone the DHIS2 is still displaying the same login error

Hey @Bollyjay_Bollyjay,
Sorry for the late reply! May I ask if you are still facing an issue? Please make sure you are connected to the internet if you are logging to the app for the first time.

Hi,

My tablets has proper wifi connection. I checked and I can surf pages in google. But, I have getting this “The user hasn’t previously authenticated. Cannot login offline”. Please suggest.

Pradeep

Hey @Pradeep . Could you try opening the same DHIS2 URL on the web browser to discard any issue while reaching that URL from your mobile?

Thank you Jaime. I did that and it worked now thank you. I am facing another issue: The mobile version is showing below issue when I tried to open one TEI to update event.

Pradeep
Regards,

Hey @Pradeep , that indeed seems like an ugly crash. Are you experiencing this in a testing server where I could get access? If yes, please PM the details. Thanks.

Hi Jaime,
I sent the details. Please check.

Regards,
Pradeep

Hello @Pradeep .

After a quick check it seems you are being severely impacted by this bug: Log in - DHIS 2 JIRA . The issue has been fixed in 2.35.8 (and you are running a previous version). If you cannot update (fully recommended) you can find a workaround in the comments. Could you check and let me know if you still have issues?

Hi @jaime.bosque,

Thank you for the suggestion. Let me upgrade the version and come back to you.

Regards,
Pradeep

Hi @jaime.bosque ,

I had Dev 2.36.4-EMBARGOED version upgraded. I tested this and having the same issues.

Uhmmm, and what about the work around provided in the comments of the issue? Please share new credentials if it doesn’t fix. I am not aware if this error is in 2.36.x as it was reported only for 2.35

I enabled the same user. I do not know how and where to fix that comments.

Taken from JIRA