We are frequently getting this error while downloading reports from line list on 2.39.8 and also on 2.40.7. Anybody else is having this issue? Also is there any workaround
Hi @jthomas
I’m trying to reproduce this issue in Line Listing app version (102.1.8) using instances (DHIS 2 Demo - Sierra Leone) and (Login app | DHIS2), and it’s actually downloading the xls files. Would you by any chance be able to reproduce this issue on play?
I’m guessing if this issue is specific to your instance, you might need to dig further in the logs Network/Console as well as Catalina.out.
Do you see any errors that might help give us a hint? Is this issue happening to superuser with ALL authority as well?
Thanks!
Issue:
In version 2.40.5, I encountered a similar problem. After checking the logs, I discovered Java was throwing the error:
“Invalid row number (65536) outside allowable range (0..65535).”
Cause:
This happens because the XLS format has a limit of 65,536 rows. If your data exceeds this limit, the export fails.
Solution:
- Download the file as CSV (no row limit).
- Save it as XLSX after downloading (XLSX supports up to 1,048,576 rows).
This avoids the XLS row limitation.