Error in syncing for Android App

Suddenly I’m facing an issue while syncing configuration while logging. Previously i haven’t faced this issue. I have deleted the remote server URL once through web and tried syncing in android app. I got this issue. So, I have added the URL back from the web. But still facing the same issue 95% of times.

Kindly help me with this issue!
Thank you!

Thanks @Katta_Nityapriya! Could you click on Share and see what details are there?

Please double check that you are entering the complete URL. For instance, in play if I want to connect to the following instance in the screenshot below, I will only enter the part and not

  • Other things to try is changing the connection when syncing. Test using different internet connection options that you have and see if there’s a difference.
  • After checking the connection, another good idea is if you have another phone which you haven’t used and see if you face the same issue.
  • You could also test connecting to any of the instances using the credentials android / android123, if it works then it’s not the connection nor the phone but actually an issue connecting to the server…

I hope these help!

Thank you @Gassim Yes, we are able to connect to And the URL entered for our instance is also correct. I’m getting the following details when I click on the “share”.

Cause: Something went wrong. Please check that server url, username and password are correct and try again.


Created: Mon Sep 04 19:14:28 GMT+05:30 2023

Http Error Code: 500

Error component: Server



The credentials entered are also correct. And I’m able to login in web. Also, I have entered only the part of the URL that is required. But not sure why I am getting this.

Usually the AutoValue_D2Error happens when the Android App finds an exception in the database, it can happen if a duplicate UID is found (for example which can happen when messing with the DB manually) but also when things are removed from the system. Have you changed the metadata recently? if you sync a new device with the same user do you get the same error?

@vgarciabnz , didn’t we start capturing the exceptions to present something more useful to the user of the crash?

Hello @Katta_Nityapriya . I might have given you a wrong piece of information after discussing with my colleague @vgarciabnz .

Could you actually take that URL you posted and put it in the browser? You will be asked for credentials the first time. If the server throws a 500 as well (very likely) then there is a problem with your metadata and you will need to see, field by field, where the problem might be.