Error executing DDL via JDBC Statement (ExceptionHandlerLoggedImpl.java

Hello everyone,

I am trying to install dhis2 version 2.26 in my ubuntu 19.10 server. I have followed Installation Guide. I have install postgresql version 12.1. After everything is setting up I tried to run dhis2. It shows the following errors in log file:

  • INFO 2019-12-08 11:18:01,167 Environment variable DHIS2_HOME points to /home/dhis/config (DefaultLocationManager.java [localhost-startStop-1])
  • INFO 2019-12-08 11:18:01,205 File /home/dhis/config/dhis-google-auth.json does not exist (DefaultLocationManager.java [localhost-startStop-1])
  • INFO 2019-12-08 11:18:01,213 Could not find dhis-google-auth.json (DefaultDhisConfigurationProvider.java [localhost-startStop-1])
  • INFO 2019-12-08 11:18:01,214 File /home/dhis/config/dhis-google-auth.json does not exist (DefaultLocationManager.java [localhost-startStop-1])
  • INFO 2019-12-08 11:18:01,214 Could not find dhis-google-auth.json (DefaultDhisConfigurationProvider.java [localhost-startStop-1])
  • INFO 2019-12-08 11:18:03,410 Hibernate configuration loaded, using dialect: org.hibernate.dialect.PostgreSQL82Dialect (DefaultHibernateConfigurationProvider.java [localhost-startStop-1])
  • WARN 2019-12-08 11:18:11,240 GenerationTarget encountered exception accepting command : Error executing DDL via JDBC Statement (ExceptionHandlerLoggedImpl.java [localhost-startStop-1])
    org.hibernate.tool.schema.spi.CommandAcceptanceException: Error executing DDL via JDBC Statement
    at org.hibernate.tool.schema.internal.exec.GenerationTargetToDatabase.accept(GenerationTargetToDatabase.java:67)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.applySqlString(SchemaDropperImpl.java:373)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.applySqlStrings(SchemaDropperImpl.java:358)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.applyConstraintDropping(SchemaDropperImpl.java:330)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.dropFromMetadata(SchemaDropperImpl.java:229)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.performDrop(SchemaDropperImpl.java:153)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.doDrop(SchemaDropperImpl.java:125)
    at org.hibernate.tool.schema.internal.SchemaDropperImpl.doDrop(SchemaDropperImpl.java:111)
    at org.hibernate.tool.schema.spi.SchemaManagementToolCoordinator.performDatabaseAction(SchemaManagementToolCoordinator.java:137)
    at org.hibernate.tool.schema.spi.SchemaManagementToolCoordinator.process(SchemaManagementToolCoordinator.java:65)
    at org.hibernate.internal.SessionFactoryImpl.(SessionFactoryImpl.java:459)
    at org.hibernate.boot.internal.SessionFactoryBuilderImpl.build(SessionFactoryBuilderImpl.java:465)
    at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:711)
    at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:727)
    at org.springframework.orm.hibernate5.LocalSessionFactoryBean.buildSessionFactory(LocalSessionFactoryBean.java:511)
    at org.springframework.orm.hibernate5.LocalSessionFactoryBean.afterPropertiesSet(LocalSessionFactoryBean.java:495)

you can see full log file in detail from below link
https://drive.google.com/open?id=1DHJkLe6F2rNKSmaVnVb1cESemjAcjOLk

Please help me to install dhis2 2.26 version, its very urgent. `
Thanks in advance!

1 Like

Hi @zerotwo,

Can you recheck your installation steps from here? DHIS2 Installation on Ubuntu 19.04 LTS – Digital Ocean – DHIS2 Web Portal

Thanks
Julhas

2 Likes

Hi julhas,

Thank you so much for the link…
I deleted everything installed before and started from the scratch now it is working fine.
In my previous installation I used postgresql version 12, open-jdk8 and tomcat8…
Now I am using postgresql-12 open-jdk8 and tomcat9 however while installation faced other errors but finally it worked… A big appreciation for your response … helped me a lot to solve problem. thanks :blush:

1 Like

Hi Sunil,

Nice to hear it is working.

No problem. :slightly_smiling_face:

Julhas

2 Likes