Error 404 on macOS installation

Am running on macOS Catalina and am getting the following error on startup.
ERROR:

HTTP Status 404 – Not Found

Type Status Report

Message Not found

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/8.5.50

Hello @xcodeTanzannia,
Welcome to the community, and thanks for your question! This issue/error can happen for so many reasons, so it’s important to know the cause.

Please which guide did you follow for the DHIS2 installation, and what version of DHIS2 are you trying to install? Other helpful info is the versions for Java and PostgreSQL database in your OS?

Make sure you created the DHIS2 user and gave the permissions using ‘chown’ to the DHIS2 configuration file. Finally, please send the Tomcat servlet catalina.out log

Thank you!:+1:

1 Like

Hi,

The 404 error message (file not found) is the local webserver letting you know that there is nothing to deliver from the URL localhost:8080/dhis-web-dashboard.
It might be that your DHIS2 installation has another address.
On my local windows PC installation I have set DHIS2 up on http://localhost:8080/dhis

Best Regards,
Paul

Thank you @Gassim for the reply,
Here is more info
DHIS2 installation guide: Getting started with DHIS2 | DHIS2 Developer Portal
DHIS2 version: d2 cluster up 2.35.0 --db-version 2.35 --seed
Java version in my OS(macOS): 16
PostgreSQL version: 13.1

1 Like

But I did not create this URL localhost:8080/dhis-web-dashboard. All I did was install docker, yarn, and the dhis2 instance. when I hit port 8080 it redirects to localhost:8080/dhis-web-dashboard

Following the official DHIS2 instructions did not work for me on Windows either. I found a couple of articles by googling that helped me, when combined with my previous experience with MS server management.
I would like to add that the security level of the default installation on Windows and probably MacOS is very low, so use it for testing and development purposes only.

Hey
So maybe if you try using an elevated session because this could also be the reason why it’s not working!

In an elevated session try this:
@austin

@Paul, thanks for sharing! May I ask what exactly didn’t work? I was able to install DHIS2 on Windows 10 using the developer’s getting started guide and it worked out well (Getting started with DHIS2 | DHIS2 Developer Portal) Thanks!

This worked for me
d2 cluster up 2.35.7-embargoed --db-version 2.35.7 --seed

But I wish some could explain to me why 2.35.0 was not working on my pc, is it because of the PostgreSQL version or java version or?..

1 Like

Close to a year ago I tried using the System Administration Guide - DHIS2 Documentation (https://docs.dhis2.org/en/full/manage/dhis-core-version-235/system-administration-guide.pdf)
which didn’t really support windows installation. It would not run on the server.

If I remember correctly, this page was useful to me.
http://dhis2trainingland.com/eportal/?tutorial=dhis2-installation-on-windows-local-server

Cheers,
Paul

Yes, you are right - it does say “This guide is not meant to be a step-by-step guide per se, but rather to serve as a reference to how DHIS2 can be deployed on a server. There are many possible deployment strategies, which will differ depending on the operating system and database you are using, and other factors”

The developers portal offers installation instructions for Windows 10 users using docker, but I’m not sure if that would help for all purposes or just the developers, any idea? (Getting started with DHIS2 | DHIS2 Developer Portal)

And thanks for sharing the link @Paul!

If I was a IT manager considering to use DHIS2 in my organisation I would want to do a test installation on my preferred platform. I would expect at least a step by step description for the major platforms, if a proper installation package was not provided.

1 Like