DHIS2 Version 2.30: Unable to see aggregate data values in pivot table


I have an issue on my dhis2 instance. I am unable to see my aggregate data values in the pivot table application even though I am able to see them in the data entry application. I have tried checking the aggregation levels, the user permissions, assigned org units, cleared cache, run analytics, switched my browser to incognito and even tried testing this on play.dhis2.org/2.30, none of which are helping. my data elements are of type Text and all of them are using option sets. I am feeling as if there is something I am missing but do not know what.

Will be grateful for any help I can get on this.

1 Like

Hi @angulube ,

I realize you mentioned the data elements are of text type on your data set; I think that might be the issue as text cannot show on pivot tables because they only show numbers/ aggregate values.

If you are not collecting aggregate values, I would recommend you use a program for this. but if you prefer on using the data sets, you might consider creating indicators for the same.


Hello James,

Thank you for the information. I always thought that the pivot table would count my text data values and then give the aggregated results. It is good to know that it is not so. I will first try using indicators and then switch to programs as you have recommended. Thanks again James.


1 Like