DHIS2 post installation error - App dashboard not found, falling back to bundled app

Hello Everyone,

I am getting started with DHIS2 for the first time.

I could manage to install the build by following this fantastic link http://dhis-2.blogspot.com/2018/02/dhis2-installation-guide-for-ubuntu.html

I used the latest github version to build the dhis.war, using build-dev.sh, it was made for docker but i did not use docker, just used the generated dhis.war

After logging in using admin/district credentials, it takes me to landing page but the spinner keeps spinning.

catalina.out file show the following lines

===============
* INFO 2020-10-08T17:30:03,380 AppOverrideFilter :: Matched for URI /dhis-web-dashboard/i18n/i18n_module_en.properties (AppOverrideFilter.java [http-nio-8080-exec-5])

  • INFO 2020-10-08T17:30:03,381 AppOverrideFilter :: App dashboard not found, falling back to bundled app (AppOverrideFilter.java [http-nio-8080-exec-5])
    ===============

am I missing something somewhere? please help

Regards
Sunder

What was the reason why you didn’t use standard war file released by DHIS2?

One option to check whether it’s a build issue or not : is to download the DHIS2 standard war file from dhis2 downloads. Use the same version you used in GitHub and restart tomcat to get the deploy effect.

Ok. I feched the file from downloads and moved it to tomcat ROOT.war
This time the web app did not work and when looked into log files for error, I see this

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'flyway' defined in org.hisp.dhis.db.migration.config.FlywayConfig: Invocation of init method failed; nested exception is org.flywaydb.core.api.FlywayException: Validate failed: Detected resolved migration not applied to database: 2.34.22
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1796)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:595)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:517)
at org.springframework.beans.factory.support.AbstractBeanFactory.lambda$doGetBean$0(AbstractBeanFactory.java:323)
at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:321)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:202)
at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:310)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:202)
at org.springframework.beans.factory.config.DependencyDescriptor.resolveCandidate(DependencyDescriptor.java:276)
at org.springframework.beans.factory.support.DefaultListableBeanFactory.doResolveDependency(DefaultListableBeanFactory.java:1287)
at org.springframework.beans.factory.support.DefaultListableBeanFactory.resolveDependency(DefaultListableBeanFactory.java:1207)
at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor$AutowiredFieldElement.inject(AutowiredAnnotationBeanPostProcessor.java:640)
... 70 more

Caused by: org.flywaydb.core.api.FlywayException: Validate failed: Detected resolved migration not applied to database: 2.34.22
at org.flywaydb.core.Flyway.doValidate(Flyway.java:268)
at org.flywaydb.core.Flyway.access$100(Flyway.java:77)
at org.flywaydb.core.Flyway$1.execute(Flyway.java:150)
at org.flywaydb.core.Flyway$1.execute(Flyway.java:142)
at org.flywaydb.core.Flyway.execute(Flyway.java:504)
at org.flywaydb.core.Flyway.migrate(Flyway.java:142)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

There is JIRA tracker available for DHIS2 and the issue that i originally posted seems to be occuring for others too. I am hoping for a solution or workaround…

Ok so here is another update. it now works!

I switched to other previous branches and tried multiple times and each time it failed with JAXB classnotfound errors. Later i switched back to master and reluctantly gave it a try and this time it worked.

Now that it works, I am happy to share this.

I need to setup a population counter POC, whereby I use android app interface on the field to collect the data. I am very new to DHIS2, any help with some pointers will be much helpful. Thank you Jin and all others.

1 Like

Thanks for the update @kollyhood Most likely your other errors happened due to when you downgrade the war files. DHIS2 in my understanding not support downgrading of war files yet.

Glad it’s working now.