DHIS2 Capture App

Hi everyone,
I can create an entity in Dhis2 Capture app and sync to the server i.e After syncronization I can view the record created on the app using web browser.
However, I cannot see the records created using the browser in my app. What could be the issue?

Hi @salad_guyo

Thank you for the post and welcome back to the community!

Since you are able to find the records created using the app in your web browser but not the opposite, this means that even though the app is connected to the server and the syncing to the server is working as expected; however, the syncing from the server to the app is not working as expected and so the most important thing to check when this happens is the sync settings in the app.

Please go to the settings in the app and check that the sync includes the syncing period to when the record you created using the browser is included. Additionally, you might want to check the other sync settings but for data set records, I think you’d first need to look at the “sync data”.

I hope this helps! Thanks!

Thanks @Gassim for your quick response.
I’m using Dhis2 Capture app version 2.8.2
I have checked Sync data, Sync configuration and Sync parameters - non of them are editable. For Sync data, Syncing period has been set to 1 Day(Default)
So just for a quick test I added a test record using the web interfaced and immediately refreshed sync on the app, last synced time seems ok but - still no data was pulled :face_with_hand_over_mouth:

1 Like

Helo @salad_guyo .

If the sync fields are not editable it is probably due to the fact of having the Android Settings Web App. Are you created those TEI in the same program / OU as the ones in the Android device? That not being the case could be due to permissions / scope.

1 Like

Thanks @jaime.bosque and @Gassim,
the issue was about user account configuration in particular org unit assignment.
Problem solved!


Hi @salad_guyo

Glad to know you have solved the issue. It seems that is what @jaime.bosque when saying

1 Like