dhis upgrade from 2.0.5 to 2.15

=0A=

···

CC: knutst@gmail.com=3B dhis2-devs@lists.launchpad.net=3B moemedi.ntunyane@=
hotmail.com
=0A=
=0A=
=0A=
=0A=
To: bobjolliffe@gmail.com

Hi=2C
I posted a similar requirement a few months back. From my experience 2.0 to=
2.10 worked fine.=0A=
=0A=
=0A=
=0A=

Regards=2C
Busoye

On 20 Aug 2014=2C at 12:12=2C Bob Jolliffe <bobjolliffe@gmail.com> wrote:=
=0A=
=0A=
=0A=
=0A=

Yes in theory they "should". Though there was much which changed between 2=
.05 and 2.10. All of the table altering stuff from earlier versions should=
be accumulated in newer versions but I recall that sometimes things did no=
t go smoothely with major jumps in versions. I guess the simple fact is th=
at incremental upgrades tend to get tested pretty heavily. Jumping version=
s becomes more of a leap of faith :-)=0A=
=0A=
=0A=
=0A=
=0A=

But I do agree=2C if someone can verify that 2.05 to 2.10 works fine=2C the=
n it would be good to hear.
I suspect the bigger problems will arise because the metadata integrity con=
trol on earlier versions was a good bit looser=2C so there will be hiccups =
caused by inconsistencies in categoryoptions=2C groupsets etc due to "broke=
n" metadata in old databases. Certainly before attempting such an upgrade =
I would consider trying to repair as much of these as possible=2C though ag=
ain without tools it is not always really easy.=0A=
=0A=
=0A=
=0A=
=0A=

Of course the most important thing is to make sure you do all of these expe=
riments in the full knowledge that you have a complete=2C verified/restored=
backup copy of the source database.
=0A=
=0A=
=0A=
=0A=
=0A=
Meanwhile I guess the answer to my earlier question is that nobody has setu=
p a dhis war museum.
RegardsBob

On 20 August 2014 11:25=2C Knut Staring <knutst@gmail.com> wrote:
=0A=
=0A=
=0A=
=0A=
=0A=
I thought Dan's point was that it would not be necessary to go through ever=
y version?
=0A=
But if it's necessary=2C maybe it would suffice to describe in simple steps=
how to build old versions.=0A=
=0A=

On Wed=2C Aug 20=2C 2014 at 12:15 PM=2C Bob Jolliffe <bobjolliffe@gmail.com= > wrote:
=0A=
=0A=
=0A=
The question of upgrading from very old dhis2 versions came up recently in =
another post.
=0A=
=0A=
=0A=
It emerged then that we don't seem to have a historical archive (museum!) o=
f war artefacts going back beyond 2.10 on http://apps.dhis2.org/ci. We do =
have the source code tagged back as far as 2.4. Has anybody kept hold of t=
hese historic build or should we consider rebuilding and making available? =
Who would volunteer to do that?=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=

On 19 August 2014 22:59=2C Knut Staring <knutst@gmail.com> wrote:
=0A=
=0A=
=0A=
=0A=
Hi Moemedi=2CNot sure=2C but I think you could try upgrading directly from =
2.0.5 to 2.13 first=2C and then run the first script. Then 2.14=2C then scr=
ipt=2C then 2.15.
If things don't work=2C you should provide the actual error messages.=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=

On Tue=2C Aug 19=2C 2014 at 6:17 PM=2C Moemedi Ntunyane <moemedi.ntunyane@h= otmail.com> wrote:
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
Hi All
I am upgrading DHIS 2.0.5 using postgreSQL DB=2C is there a shortcut other =
than using incremental way like 2.0.5=2C 2.0.6 ......to 2.15. Directly exec=
uting scripts from http://www.dhis2.org/download/resources/sql/convert-fixe=
d-attributes-to-dynamic.sql gives errors like column does not exist.
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=

Moemedi Ntunyane
Co-founder KeyInConsulting
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=
=0A=