Dhis 2.33 Event Report/Visualizer Issue

Hello Everyone

I’m facing an issue when I’m trying to use Event Report/Visualizer apps with Data Element Linked with option Set, Like Gender (M,F). I don’t get a result, the spinner spins indefinitely.
When I use only simple Data Element, I get result.

Here is the error in log

Query failed, likely because the requested analytics table does not exist (AbstractJdbcEventAnalyticsManager.java [tomcat-http-16])
org.springframework.jdbc.BadSqlGrammarException: StatementCallback; bad SQL grammar [select avg(distinct tei) as value from analytics_enrollment_xkodytbxqxb as ax where enrollmentdate < cast( ‘2021-01-01’ as date )and enrollmentdate >= cast( ‘2020-01-01’ as date )and (uidlevel1 = ‘Ky2CzFdfBuO’ ) limit 100001]; nested exception is org.postgresql.util.PSQLException: ERROR: function avg(character) does not exist
Hint: No function matches the given name and argument types. You might need to add explicit type casts.

Updating 1 object(s) of type Program (DefaultObjectBundleService.java) [system-process]
com.fasterxml.jackson.databind.JsonMappingException: failed to lazily initialize a collection of role: org.hisp.dhis.category.CategoryCombo.userGroupAccesses, could not initialize proxy - no Session (through reference chain: org.hisp.dhis.program.Program[“categoryCombo”]->org.hisp.dhis.category.CategoryCombo[“userGroupAccesses”])

Caused by: org.postgresql.util.PSQLException: ERROR: relation “analytics_event_xkodytbxqxb” does not exist.

I need a help please.

Thank you

1 Like

Hi @didate,

Welcome to the DHIS2 community and congrats on your first post!

Have you been to run analytics tables without errors? Seems like the error is saying that the event analytics tables do not exist?

Can you give us some steps to reproduce and potentially see if you can reproduce the issue in our demo servers (play.dhis2.org)?

Also tagging @dhis2-backend for attention.

Thanks,
Karoline

Hello @Karoline
I solved the problem, I think, it was the fact that I imported the set options from version 2.30 to version 2.33. I re-create them manually and it works now. It may be related to uids of default objects …

Thank you for your response.

Regards