Datamart Problem

Dear Users

I'm new to DHIS and I have a problem.

After I run datamart, login, and download Metadata I cannot update Aggregate data. Enclosed is the log file.

Kabango Malewezi | Database Specialist

SSDI Services

2nd Floor, Pamodzi House, City Center, P.O Box 1091, Lilongwe, Malawi
Tel: +265 (01) 776 412/3/4 | fax: +265 (01) 776 410 | Mobile: +265 (0) 88 4 245 431

kmalewezi@jhpiego.net <mailto:kmalewezi@jhpiego.net > | www.jhpiego.org<http://www.jhpiego.org/>

Skype: kabango.malewezi | Twitter: kabangoM

Datamart Error.txt (14.2 KB)

Hi Kabango

This is an odd error but I believe it is probably caused because you
are missing resource tables on the dhis server side. On dhis server
go to:

data administration -> resource tables -> select all -> generate tables

and try again.

Regards
Bob

···

On 27 June 2012 15:32, Kabango Malewezi <kmalewezi@jhpiego.net> wrote:

Dear Users

I'm new to DHIS and I have a problem.

After I run datamart, login, and download Metadata I cannot update Aggregate data. Enclosed is the log file.

Kabango Malewezi | Database Specialist

SSDI Services

2nd Floor, Pamodzi House, City Center, P.O Box 1091, Lilongwe, Malawi
Tel: +265 (01) 776 412/3/4 | fax: +265 (01) 776 410 | Mobile: +265 (0) 88 4 245 431

kmalewezi@jhpiego.net <mailto:kmalewezi@jhpiego.net > | www.jhpiego.org<http://www.jhpiego.org/>

Skype: kabango.malewezi | Twitter: kabangoM

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Hi Bob,

Thanks a lot. I was having a similar problem with datamart but it was fixed once I generated tables.

Ese

···

On Wed, Jun 27, 2012 at 4:04 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

Hi Kabango

This is an odd error but I believe it is probably caused because you

are missing resource tables on the dhis server side. On dhis server

go to:

data administration -> resource tables -> select all -> generate tables

and try again.

Regards

Bob

On 27 June 2012 15:32, Kabango Malewezi kmalewezi@jhpiego.net wrote:

Dear Users

I’m new to DHIS and I have a problem.

After I run datamart, login, and download Metadata I cannot update Aggregate data. Enclosed is the log file.

Kabango Malewezi | Database Specialist

SSDI Services

2nd Floor, Pamodzi House, City Center, P.O Box 1091, Lilongwe, Malawi

Tel: +265 (01) 776 412/3/4 | fax: +265 (01) 776 410 | Mobile: +265 (0) 88 4 245 431

kmalewezi@jhpiego.net <mailto:kmalewezi@jhpiego.net > | www.jhpiego.org<http://www.jhpiego.org/>

Skype: kabango.malewezi | Twitter: kabangoM


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

I am wondering if anyone can be of help…I am having issues with the GIS module.

I downloaded a shape file for my country and converted one of the extracted files (NGA_adm2.shp) to GML using ogr2gui.

I further changed the “NAME_2” tag as directed. Finally, I made sure that the names in my gml file have exactly the same names as the org unit names in DHIS.

The problem is that nothing happens when I import the GML file to DHIS. All the elements show “none”

···

On Fri, Jun 29, 2012 at 12:20 AM, Ese Egerega ese@cis.com.ng wrote:

Hi Bob,

Thanks a lot. I was having a similar problem with datamart but it was fixed once I generated tables.

Ese

On Wed, Jun 27, 2012 at 4:04 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

Hi Kabango

This is an odd error but I believe it is probably caused because you

are missing resource tables on the dhis server side. On dhis server

go to:

data administration -> resource tables -> select all -> generate tables

and try again.

Regards

Bob

On 27 June 2012 15:32, Kabango Malewezi kmalewezi@jhpiego.net wrote:

Dear Users

I’m new to DHIS and I have a problem.

After I run datamart, login, and download Metadata I cannot update Aggregate data. Enclosed is the log file.

Kabango Malewezi | Database Specialist

SSDI Services

2nd Floor, Pamodzi House, City Center, P.O Box 1091, Lilongwe, Malawi

Tel: +265 (01) 776 412/3/4 | fax: +265 (01) 776 410 | Mobile: +265 (0) 88 4 245 431

kmalewezi@jhpiego.net <mailto:kmalewezi@jhpiego.net > | www.jhpiego.org<http://www.jhpiego.org/>

Skype: kabango.malewezi | Twitter: kabangoM


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi Ese,

there are a couple of other possible error causes in the gml as well, like orgunit duplicates and names that are too long for the shortname column in the database. The server log will probably give you a hint, so please have a look if you have access to it.

···

On Thu, Jul 5, 2012 at 4:42 PM, Ese Egerega ese@cis.com.ng wrote:

I am wondering if anyone can be of help…I am having issues with the GIS module.

I downloaded a shape file for my country and converted one of the extracted files (NGA_adm2.shp) to GML using ogr2gui.

I further changed the “NAME_2” tag as directed. Finally, I made sure that the names in my gml file have exactly the same names as the org unit names in DHIS.

The problem is that nothing happens when I import the GML file to DHIS. All the elements show “none”

On Fri, Jun 29, 2012 at 12:20 AM, Ese Egerega ese@cis.com.ng wrote:

Hi Bob,

Thanks a lot. I was having a similar problem with datamart but it was fixed once I generated tables.

Ese

On Wed, Jun 27, 2012 at 4:04 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

Hi Kabango

This is an odd error but I believe it is probably caused because you

are missing resource tables on the dhis server side. On dhis server

go to:

data administration -> resource tables -> select all -> generate tables

and try again.

Regards

Bob

On 27 June 2012 15:32, Kabango Malewezi kmalewezi@jhpiego.net wrote:

Dear Users

I’m new to DHIS and I have a problem.

After I run datamart, login, and download Metadata I cannot update Aggregate data. Enclosed is the log file.

Kabango Malewezi | Database Specialist

SSDI Services

2nd Floor, Pamodzi House, City Center, P.O Box 1091, Lilongwe, Malawi

Tel: +265 (01) 776 412/3/4 | fax: +265 (01) 776 410 | Mobile: +265 (0) 88 4 245 431

kmalewezi@jhpiego.net <mailto:kmalewezi@jhpiego.net > | www.jhpiego.org<http://www.jhpiego.org/>

Skype: kabango.malewezi | Twitter: kabangoM


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi,

we will put in scheduled jobs for the resource tables as a start. If
that is insufficient we will have to consider other options too.

Lars