Data visualizer : No data available when i using OrgUnit Group Set as data dimension

Hello, DHIS2 community,
I’m having a problem with a Data visualizer Module. When I analyze the data, everything looks fine, as shown in the image below :

But when I added data dimension (Networks) and created it from the OrgUnit group set, Show me a message The selected dimensions didn’t return any data. There may be no data, or you may not have access to it.
as shown in the image below :

Note : I am using DHIS2 version 2.38.2, and I reproduce it on demo version; everything works fine.

After running analytics tables export and performing Maintenance (clear application cache & reload apps) from the Data Administration app. Please try to test again by logging into your instance in Guest mode

If there’s still the same issue, could add the steps to reproduce this? Additionally, a screenshot of errors in the Network tab and the console would help.

Thank you!

1 Like

@Gassim Thanks for your assistance.
The problem was that it was one of the organizational units within the group set for which the data set had not been activated.

Best regards

So was it solved? Was the dataset assigned to the OU that was in the group? :thinking::+1:


Yes, I assigned the dataset to the OU in the group, and it works fine in the data visualizer.

1 Like