Data visualizer error when selecting more than one year

In the data visualizer when I choose the period for more than a year an error message appears as following:
Something went wrong

There was a problem getting the data from the server.
But if I select the period on one year or less for example last 3 months that visuals appears normally.
Please help.

1 Like

Hi @Manaf_Aladomi

Would it be possible to test which exact period results with this error? For example, if you pick fixed months from January 2023 - February 2024 keep adding a fixed month until the error appears and then try that month alone. What I mean by this is so you could figure out for which period is this happening exactly and see that you actually have data there.

When you figure out the exact period that’s causing this issue, it might also help to check the console and network tabs in the DevTools (F12) then share screenshots please.

Thanks!

3 Likes

Hi @Gassim I am facing the same error but in my case it happens for any random time frame be it future or past. I am on version 2.37.9.1

1 Like

Thanks @Sweety_Sharma for the info!

Yes, that’s expected to happen when there’s no data present. If it’s working for previous periods then that’s good.

Hi @Gassim we just noticed its happening irrespective of time interval when data is not present. But at times even when data is not present it does not give the error.
We are in version 2.37.9.1. Can you explain in which use cases this error is thrown?

Hi again,

Is there a chance you could share a step by step on how to reproduce this issue?

Thanks!

Hi Boss @Manaf_Aladomi

check the console and network tabs in the DevTools of browser by click on (F12 or FN+ 12) then share screenshots please.

2 Likes

Thanks all, I could solve the problem, it needed system update and restart from the cloud server console

1 Like

Hi @Manaf_Aladomi by update you mean you upgraded DHIS version?

Hi @Gassim Here are the steps:

  • Go to data visualiser app
  • Select some data
  • Select a period which doesn’t have any data (I choose may 2015)
  • Click on update it would show ->No data available. The selected dimensions didn’t return any data. There may be no data, or you may not have access to it.
  • Once updated click on save then we get-> Something went wrong. There was a problem getting the data from the server.

This i could reproduce only in 2.37.9.1

Hi! this is Tariq Khan from Pakistan, I am new to this platform.
I have some suggestion which may be resolve the data visualizer error message.
As per my experience this issue appears by two reason.

  1. If there is some updates/work running on DHIS2 Plat Form/Portal by the DHIS2 administrators. the data visualizer may give this message.
  2. If the data visualizer in DHIS2 gives this error message you may clear the browser Cache data or system cache data will resolve this issue.
1 Like

No just update the cloud server once you login to the server it will require you to update, and then restart the server, I did this and it worked.

2 Likes

Hi

That’s expected because if there’s no data, it shouldn’t return anything.

Welcome to the DHIS2 Community! Thank you for sharing with your fellow community members.

Good to know this worked! Thanks!

Dear Alghassim,

Now I am having the same issue but this time when selecting more than 6 periods in the visualizer, and am getting this message issue in the network console here I am attaching the screenshot, knowing that I have deleted the cache of the browser

dhis2
please help