Data Visualizer error after upgrading to

Hi, I updated my DHIS2 version from to
Now, when I open Data Visualizer and try to test some program indicators, I get the following error

My server specs are:
CPU cores = 8
RAM = 32GB
OS = Ubuntu 18.04
PostgreSQL 13.10
Tomcat 9
Java 11, -Xms8184m -Xmx12288m
here are some tomcat logs with error

Can you paste the formulae screenshot of program indicators for more info

1 Like

Hi @jthomas

Best regards

1 Like

can you remove Circumcision Procedure start time temporarily and see it still creates problem? (you need to browser clear cache and try)

I think that condition can be put as d2:hasValue(Circumcision time)

I tried both, removing Circumcision Procedure start time, and using d2:hasValue(Circumcision Procedure start time).
But now Data Visualizer says I have no data, but when I look at the logs it gives the same error as before

1 Like

Is this happening for other indicators also? It seems we need a bit of troubleshooting on this, may be i would go minimizing indicator to just count all and then keep putting conditions one after another till we get the problem

Please try to run analytics tables export from the Data Administration app, and in the same app go to Maintenance → clear application cache, reload apps. After that please try again in your browser’s Guest mode (not incognito)


I got a similar console error while trying to confirm a bug on Enrollment analytics type. That bug may be related to your experience.

1 Like

Hi @Gassim I’ve tried that many times but with no luck. It seems that for some reason it is not recognizing my program indicators anymore