Data Quality App on Follow-Up Analysis download is not working

Hi All,

I am running DHIS locally and I found that on Data Quality App Follow-Up Analysis all downloads not working (PDF, excel,…) I think it is a bug, or if it is from my side help me to fix it.

The second bug is in the Data Quality app all downloads add a double slash on the URL when we run it locally it generates an error can you remove the double slash from all download links(URL)

Best regards

Hi @Beruck

Yes, thanks! I was able to reproduce this on for the two latest instances. Would you please like to create a jira bug issue? Here and share it with the community so others can watch/vote/comment.

Does removing the double slashes actually solve the problem? The following is a link with double slashes and it works too! DHIS 2 Demo - Sierra Leone


Yes removing the double slash solve the problem.

1 Like

Thank you for sharing the workaround. It’d still be helpful if we report a bug issue!

I tried to remove the slashes but it didn’t solve the problem. Could you try in the instance if you can reproduce the issue and the workaround?

Thank you!

I manually right-click on the download link and open in new tab, then remove the double slash this for Validation Rule Analysis for Follow-Up Analysis completely not working. Like this

after removing the double slash

it works

With or without double slashes it’s working for me in the Data Validation, but when I tried the Follow-Up, it’s not working!

Could you try as well? Thanks!

Yes, Follow-Up, it’s not working! But for Data Validation also it will not run locally unless I remove the double slash.


1 Like