Data not synchronizing on Android

Hi folks, kindly in need of assistance.

We’re using the capture app v2.51 and the Android web app v2.0.0.
The Maximum TEI downloads is 2000 and the event is set to 3000 [Setting level:Global]

On Global synch settings, the meta-data is specified for 1 Day while the data synch at 30minutes.

We had 102 sync error logs on which 101 are eliminated. The current error we are facing is this:
"Null Server
Unexpected exception"

@Markus @YuryR @Gassim looking forward for your assistance :slight_smile:

Thanks in Advance

hi @Don_Vieira .

I am not sure I understand what you mean by 101 out of 102 are eliminated. Could you please clarify? If you are having issues while syncing the TEIs you should be able to go the program and see some TEI with the error (marked as red) by trying to sync a TEI individually you might be able to see a more descriptive error. In any case, an error about the server makes me thing there might be a problem with your connectivity/server… or maybe it was a temporary thing?

Let me know. Cheers

1 Like

Hi @jaime.bosque thanks for your response

My apologies let me rephrase that,
The app is only allowing us to download the TEI’s one by one. We’ve set the Maximum TEI downloads to 2000 and the Maximum event to 3000. In normal circumstances, this should automatically download the TEI to the tab.

We’d like to have those records locally saved on the tablet.

We are currently getting this error under the Synch log error: "Null Server
Unexpected exception". We do not have internet connectivity issues. This issue was experienced since last week.

Our assumption is that the errors are affecting the downloading of TEIs and events

Hi @Don_Vieira.

The settings in the Android Settings Webapp can determine how many TEIs to download so what you are trying to do is the correct way. A couple of questions:

  1. Have you enabled this settings for a specific program or generally?
  2. Have you tried resetting the app and seeing if the TEIs are downloaded?
  3. Are the TEIs you want to download under the capture scope of the user in the Android device?


1 Like

Hi Jaime,

This is resolved, we simply had to roll back to an earlier version of the Android App. It works in all versions except Versions 2.5.1 and 2.5.2

Hi @Don_Vieira

I am happy to read that it got solved. However, I would like to know what can be the issue as if it is present in later versions of the app as a bug and we don’t fix it, it will keep being present. Could you provide a testing account to the server or describe in details so we can replicate?