Data not showing up in Pivot Table

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

···

Regards,

Leke Seweje

https://docs.dhis2.org/2.23/en/user/html/ch33.html

···

On Mon, May 14, 2018 at 8:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Department of Information, Evidence and Research
World Health Organization, Geneva, Switzerland
Office: +41 22 791 3683 Mob1: +33 6 4434 2931 Mob2: +47 9188 0522
Skype: knutstar

Hi Olaleke,

Review your user rights if your account is allowed to do analysis.Make sure you are not restricted to do analysis.

This should work.

Stanley

···

On Mon, May 14, 2018, 08:05 Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?


Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

run analytics

···

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

I am running it now but it’s been going on for about 5 mins. For only one form filled just once, should that be normal?

···

On Mon, May 14, 2018 at 7:29 AM, Timothy Kiyemba tkiyemba@gmail.com wrote:

run analytics

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

No that is not normal.Try to reboot the system and re run the processes.

···

On Mon, May 14, 2018 at 7:29 AM, Timothy Kiyemba tkiyemba@gmail.com wrote:

run analytics


Regards,

Leke Seweje

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Okay, let me do that and see.

···

On Mon, May 14, 2018 at 7:45 AM, Stanley Kalyati skalyati@gmail.com wrote:

No that is not normal.Try to reboot the system and re run the processes.

On Mon, May 14, 2018, 08:41 Olaleke Seweje sewejeolaleke@gmail.com wrote:

I am running it now but it’s been going on for about 5 mins. For only one form filled just once, should that be normal?


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Mon, May 14, 2018 at 7:29 AM, Timothy Kiyemba tkiyemba@gmail.com wrote:

run analytics


Regards,

Leke Seweje

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

And then look at your Tomcat log for any errors as you run analytics.

···

On Mon, May 14, 2018 at 8:59 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Okay, let me do that and see.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Mon, May 14, 2018 at 7:45 AM, Stanley Kalyati skalyati@gmail.com wrote:

No that is not normal.Try to reboot the system and re run the processes.

On Mon, May 14, 2018, 08:41 Olaleke Seweje sewejeolaleke@gmail.com wrote:

I am running it now but it’s been going on for about 5 mins. For only one form filled just once, should that be normal?


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

On Mon, May 14, 2018 at 7:29 AM, Timothy Kiyemba tkiyemba@gmail.com wrote:

run analytics


Regards,

Leke Seweje

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Department of Information, Evidence and Research
World Health Organization, Geneva, Switzerland
Office: +41 22 791 3683 Mob1: +33 6 4434 2931 Mob2: +47 9188 0522
Skype: knutstar

Thanks all but I am still not able to access data in Pivot.
However, after rebooting the computer, I am still able to call up the data I entered on the Data Entry app (image below) which means the data is actually there in the DB.

I ran analytics again and this time it gave me a success confirmation message but data still not showing in Pivot.

Looking like a permission problem to me. If so, can you please tell me what permission to set in particular?

Thanks

···

On Mon, May 14, 2018 at 8:03 AM, Knut Staring knutst@gmail.com wrote:

And then look at your Tomcat log for any errors as you run analytics.

On Mon, May 14, 2018 at 8:59 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Okay, let me do that and see.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Department of Information, Evidence and Research
World Health Organization, Geneva, Switzerland
Office: +41 22 791 3683 Mob1: +33 6 4434 2931 Mob2: +47 9188 0522
Skype: knutstar

On Mon, May 14, 2018 at 7:45 AM, Stanley Kalyati skalyati@gmail.com wrote:

No that is not normal.Try to reboot the system and re run the processes.

On Mon, May 14, 2018, 08:41 Olaleke Seweje sewejeolaleke@gmail.com wrote:

I am running it now but it’s been going on for about 5 mins. For only one form filled just once, should that be normal?


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

On Mon, May 14, 2018 at 7:29 AM, Timothy Kiyemba tkiyemba@gmail.com wrote:

run analytics


Regards,

Leke Seweje

On Mon, May 14, 2018 at 9:04 AM, Olaleke Seweje sewejeolaleke@gmail.com wrote:

Hello all,
I have just created my first DHIS data set, entered data for data elements for the set and completed the form successfully. However, when I go to the Pivot Table app to check, the data does not show up.

I have selected same organization units and period as I selected while filling the form.

Please is there something I need to do to make the data show up?

Regards,

Leke Seweje


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

Hi Leke,

Kindly share the image of the pivot table results also.

Thanks.

Adedayo

Untitled (242 Bytes)

···

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 8:27, Olaleke Seweje > sewejeolaleke@gmail.com wrote:


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Hello Adedayo,
i have shared the image here.

Also, I cleared my browser cache and now I can see data for data elements

But still no data if i try to query with the data sets.

Is there some setting I should do to make the data show for data sets too?

Thanks

···

On Mon, May 14, 2018 at 9:08 AM, Dayo Adeyomoye deemoyes@yahoo.com wrote:

Hi Leke,

Kindly share the image of the pivot table results also.

Thanks.

Adedayo

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 8:27, Olaleke Seweje

sewejeolaleke@gmail.com wrote:


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Regards,

Leke Seweje

Hi Leke,

Now seen. What is the data aggregation level of each data element in the data element module. If thw aggregation level of thw data elemenr is higher than the org unit level at which data is entered, the data are not show.

Please you may check that. And since the data already showed up for the data elements, you can also try to run maintenance under Data administration and then restarting.

Meanwhile, did you try changing your browser just to also be sure.

···

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 9:33, Olaleke Seweje > sewejeolaleke@gmail.com wrote:

Hello Adedayo,
i have shared the image here.

Also, I cleared my browser cache and now I can see data for data elements

But still no data if i try to query with the data sets.

Is there some setting I should do to make the data show for data sets too?

Thanks

On Mon, May 14, 2018 at 9:08 AM, Dayo Adeyomoye deemoyes@yahoo.com wrote:

Hi Leke,

Kindly share the image of the pivot table results also.

Thanks.

Adedayo

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 8:27, Olaleke Seweje > > > sewejeolaleke@gmail.com wrote:


Mailing list: https://launchpad.net/~dhis2- users
Post to : dhis2-users@lists.launchpad. net
Unsubscribe : https://launchpad.net/~dhis2- users
More help : https://help.launchpad.net/ ListHelp


Regards,

Leke Seweje

Hi Adedayo,
Thanks for your response. Please correct me if I’m wrong but data element aggregation is a data element issue. I checked it as you said though but as seen in the images, the data elements show up when I query, it is when I query on data sets that it returns blank.

What options do i need to select under Maintenance as I have already done so for ‘Reload apps’ and ‘Clear application cache’ options earlier.

And yes, I have changed my browser.

However, let me describe my steps maybe there is something I missed along the line.

  1. I created org units

  2. created data elements (all with aggregate domain type)

  3. created a data set and added some of the data elements. I also selected the root org unit for the data set

  4. I went to data entry app and selected the data set, period and the same org unit form step 3

  5. filled the form, validated, and clicked ‘complete’. (My understanding here is that the application will sum all the data element and assign as final value of the data set in analytics). So if I have Implant and Diaphragm and enter 2 and 3 for them, the data set should automatically give me 5 when i query. Is that correct and does it happen automatically or do I have to set it to do that somewhere?)

  6. I ran Reports->analytics->start export to update the analytics tables as earlier advised on this thread

  7. cleared my browser and application cache under data administration -> maintenance, then data elements came up in pivot

  8. tried for data sets, got nothing

Please let me know if the steps are correct. Thanks

···

On Mon, May 14, 2018 at 10:27 AM, Dayo Adeyomoye deemoyes@yahoo.com wrote:

Hi Leke,

Now seen. What is the data aggregation level of each data element in the data element module. If thw aggregation level of thw data elemenr is higher than the org unit level at which data is entered, the data are not show.

Please you may check that. And since the data already showed up for the data elements, you can also try to run maintenance under Data administration and then restarting.

Meanwhile, did you try changing your browser just to also be sure.

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 9:33, Olaleke Seweje

sewejeolaleke@gmail.com wrote:

Hello Adedayo,
i have shared the image here.

Also, I cleared my browser cache and now I can see data for data elements

But still no data if i try to query with the data sets.

Is there some setting I should do to make the data show for data sets too?

Thanks

On Mon, May 14, 2018 at 9:08 AM, Dayo Adeyomoye deemoyes@yahoo.com wrote:

Hi Leke,

Kindly share the image of the pivot table results also.

Thanks.

Adedayo

Sent from Yahoo Mail on Android

On Mon, 14 May 2018 at 8:27, Olaleke Seweje

sewejeolaleke@gmail.com wrote:


Mailing list: https://launchpad.net/~dhis2- users
Post to : dhis2-users@lists.launchpad. net
Unsubscribe : https://launchpad.net/~dhis2- users
More help : https://help.launchpad.net/ ListHelp


Regards,

Leke Seweje

Regards,

Leke Seweje