Data not exported from database using Data Administrator app

I have some data captured for some OUs. After I exported data using the Data Administration app, I check with the Data Visualizer app and no data is showing.

Meanwhile, I can confirm that in some facilities, the data was showing but not showing for some. I can also confirm that the data is stored in the datavalue table in the database. Any possible reason why the data is not showing?

Thanks for your post @jetisco4u!

Confirms that the sharing settings for the data set are configured properly. However, it might be that some of these facilities are not properly assigned to the user? Could you check the OUs assigned to the user?

Using your browser’s Guest mode, would you open the page where the values are not appearing and after opening the Network tab as well as the Console in the DevTools (F12) refresh the page? Are you seeing any errors could you take screenshots of these error messages?


The Sharing settings seems ok because some facilities are showing and I am accessing as a super admin

I think the facilities are assigned. Besides, I tested this as a super admin with a site-wide access.

For this I access the site in Guest Mode and still the same error message like below.

Could you test moving the Dimensions between Series, Category and Filter?

If you check the analytics? endpoint requests, do you see any values? Copy the request URL from the Networks tab, are you able to see the values return when opening using JSON?


This doesn’t work

When I checked the endpoint request, I can see that there is data. In the level 2 OUs, the facilities data shows, but in some of these cases, the level 2 OUs don’t show record for the facilities.

This issue remain unresolved

Thanks for the bump @jetisco4u!

Would it be possible please to try to reproduce the issue on any of the instance, and then share the steps to reproduce? It seems like it needs more testing. Thanks! :thumbs_o_up:

Well I wish I could. But I used a custom app to capture the data. All I can say is that we are getting the data in the Data Visualizer app for some facilities but for others it is not showing. I check the database and can confirm that the data is in the datavalue table but it’s not showing in the Data Visualizer app. And I am using the same facility OU to capture data for other dataset which we can access with the Data Visualizer app.

I don’t know why data stored in datatvalue table is not being exported for analytics.

Hi @jetisco4u ,

It would be good to try and confirm that the data is also in the analytics tables. You had mentioned its in the raw data tables (datavalue). What about the analytics tables? Did you check there as well?

I would suggest you check your DHIS2 server logs when you are attempting to get data for these particular organisation units. I have seen situations where the geometry of an organisation unit is corrupt, and may cause an analytics query to fail. This may not be apparent through the browser, but it is visible in the server logs.

If it is still not visible in the server logs, then you may need to enable Postgresql logging and see if you see anything there.

Best regards,

Thanks. I am seeing 3 analytics tables which are analytics, analytics_2022 and analytics_2023. Are you referring to the first one?

The analytics tables are partitioned by year, so each of those tables “analytics_2022” etc contains data for the referenced year. The “dx” column contains the data element UID, and the “ou” column the organisation unit UID. Have a look in one of those tables and see if the data is present.


I have checked the analytics table and can confirm there is no data in the table.

The funny part is that I have captured data for same OU for other datasets and the data are showing in the Data Visualizer app.

Any help on this?

I checked and the data is in the Analytics table in some instances but not appearing in the Data Visualizer App.

So far, I noticed that when I capture the data with my custom app, the value is not showing in the Data Visualizer app. But when I capture it with the Data Entry app, it is showing. And when I check the datavalue table in the database the data is there as well.

Also when I open the Data Entry app, the values I already captured with my app is not prepopulated.