Data is not display in the Pivot table

Dear Friends,

Can someone help me that how to figure out the problem I faced with data display issue in the pivot table. See bellow the problem;

When I enter the data through data entry app or import data, the data is not showing in the pivot table, however I set the scheduler from (Scheduler app) to run analytic table at everyday 3 AM, but still no data in the next days, but if manually to run the analytic table from data administration the data is shown.

DHIS2 2.32.4

Appreciate the advice.

HI @Ibrahimi, After setting the Scheduler; have you tried checking when the last analytics table generation was (before manually running it)? maybe the scheduled job isn’t running as you need it to/ maybe how you have configured the job*

Thank you James,

This is the problem, the scheduled Job isn’t running as scheduled, So would could be the resolution for this problem?


Dear James,

Please could you help me to set up the scheduler to run automatically, see following scan of the system info, the analytic table has not updates science I did update manually on 25 March.


Hi @Ibrahimi

Please look for the ‘Scheduler’ app

Add new job for Analytics table if one does not exists, as seen in the screenshot below:

In Job Type select Analytics Table

Click on Add Job

This will ensure that analytics will run every night.

Dear Saurabh,

Thank you for the advice, and instruction, I follow your instruction and update the scheduler, but still the analytic has not run, and not updated data shown in the pivot table and also the system status shows no updated analytic run? see my scheduler snapshot. Please, is there

any other option that I have to check it?

Hi @Ibrahimi,

Last screenshot suggests that scheduler app attempted to run analytics, but something went wrong. Could you check the server logs and see if there were any errors during the analytics run?

/ Gintare

yes check the server logs for details about what’s going on when the analytics is run. it looks like there is something preventing the schedular from completeing the run. I’ve had the same problem and it got solved but to the moment I don’t know what was the error and how it got fixed :sweat_smile: