Data entry form is not visible when trying to use the capture app

Thank you for the new version release. I am testing it using an event program and my data entry form is not visible when trying to use the capture app. I am able to see the only the basic info. any suggestion why this is happening. below is the screenshot.

1 Like

I had a similar problem. In my case, earlier versions of DHIS 2 had assigned a dataEntryForm UID to my section-based event program. To be the best I could tell, this dataEntryForm UID was no longer used in the later version of DHIS 2, but the system was still reading the dataEntryForm and trying to load it. Since the form was empty, it was loading nothing. Assuming you’re not trying to use a custom form, I’d check the metadata and see if there’s a dataEntryForm assigned to the program. In my case, removing this dataEntryForm solved the problem.

1 Like

@sean.leland.dryer I was using section forms in the previous version. should I remove that and re-do it again OR total remove it?


It looks like the JIRA ticket Calle referenced has a simpler/less risky fix than what I’d done, so I’d follow those instructions:

If you don’t have a Jira account, I’ll copy the instructions here:
Temporary workaround to fix programs that has been broken by a blank data entry form:

  • Open the program in maintenance.
  • Go to “3. Create data entry form”
  • Select the “Custom” tab
  • Click the delete button at the bottom of the screen (this deletes the blank custom form from the server directly)
  • Do not click the “Save” button at the bottom of the screen - as long as the current bug exists, this would reintroduce a blank custom form. Close the maintenance app without any further actions.
  • Clean cache and open the Capture app - everything should work normally again.

I hope this fixes your problem!


@sean.leland.dryer in my previous version I was using section form/not custom form. does this work fro that too?


@sean.leland.dryer @Calle_Hedberg Thank you, it is solved now!

1 Like


Good that it’s solved.

Rather weird, though, that my post on this thread seems to have disappeared. Not sure what’s going on here…