Data Capture App does not work

Hey all
I am setting up a DHIS 2.29 instance where I have already set data elements and entity attributes for a tracker program. Now when i try to open up the Tracker Capture app from browser, I get this page.

At right you can see some APIs have 400 Bad Request Errors. When I try these links in my browser I get a blank page.

Any idea on how to solve this?

PS: This error also shows up in v 2.31. I think this has something to do with the number of square brackets, but I am using tomcat 7 with java 8. I have already cleared browser cache and i have tried this on 3 different browsers.

When I use the same URL with same parameters, headers and everything, and I hit it via Insomnia (a REST Client) I get correct output. But If I open the URL in browser or use jQuery Ajax from Browser console it fails.


So I found the reason, why it was working on Insomnia and not in browser. Insomnia was automatically escaping [ by URL decoding them, where as the browsers pass AJAX requests as is. This meant [ was not being escaped and Tomcat was bugging out. Using this, i allowed [ in query params and now it works!

Thanks and Regards

1 Like

This is great @salik.merani! thank you for the update too.