D2 Cli database scripts failure @ cross-spawn on Windows

Hi, spun up a local cluster 2.39 successfully but without database on Windows 10
–seed, backup and restore commands fail with error at cross-spawn
Completely reloaded node.js DHIS2 etc. thinking my older node.js install somehow broken but clean sweep produces same result.
Currently repeating install on Ubuntu but Windows docker would be more convenient.
Hoping this is just simple newbie fix but haven’t found it in docs or here…
--------------------(sample error, --seed and restore equivalent errors)-------------------------
C:\Users\newby>d2 cluster db backup --fat 2.39.01 nwnbackup
Backing up database (this may take some time)…
Performing fat backup, including Analytics and Resource tables
‘.’ is not recognized as an internal or external command,
operable program or batch file.
throw er; // Unhandled ‘error’ event

Error: spawn ./scripts/backup.sh ENOENT
at notFoundError (C:\Users\newby\AppData\Roaming\npm\node_modules@dhis2\cli\node_modules\cross-spawn\lib\enoent.js:6:26)
at verifyENOENT (C:\Users\newby\AppData\Roaming\npm\node_modules@dhis2\cli\node_modules\cross-spawn\lib\enoent.js:40:16)
at cp.emit (C:\Users\newby\AppData\Roaming\npm\node_modules@dhis2\cli\node_modules\cross-spawn\lib\enoent.js:27:25)
at ChildProcess._handle.onexit (node:internal/child_process:291:12)
Emitted ‘error’ event on ChildProcess instance at:
at cp.emit (C:\Users\newby\AppData\Roaming\npm\node_modules@dhis2\cli\node_modules\cross-spawn\lib\enoent.js:30:37)
at ChildProcess._handle.onexit (node:internal/child_process:291:12) {
code: ‘ENOENT’,
errno: ‘ENOENT’,
syscall: ‘spawn ./scripts/backup.sh’,
path: ‘./scripts/backup.sh’,
spawnargs: [ ‘C:\Users\newby\nwnbackup’, ‘full’ ]

Node.js v18.14.0

Thanks! Nigel

Hi @nwn

Welcome to the community and thank you for your post!

Could you try 2.39.1 (the latest release) instead and see if it works?

d2 cluster db backup --fat 2.39.1 nwnbackup


Hi Gassim, thanks for the advice. I tried the latest db and the latest D2 again with same result unfortunately.
Some good news though, I have completed a setup on an Ubuntu Hyper-V VM which is working just fine so I now have a better grasp of postgresql and tomcat and a working DHIS2 instance for learning more.
Thanks to all for a great system!