Current user is constrained by a dimension but has access to no dimension items

I posted a json dataValue to the backend through Postman. When I check the database, the value is recorded. But when I tried to access this through the visualisation app, I got the error below:

httpStatus: "Conflict", httpStatusCode: 409, status: "ERROR",…}
errorCode: "E7123"
httpStatus: "Conflict"
httpStatusCode: 409
message: "Current user is constrained by a dimension but has access to no dimension items: `xYerKDKCefk`"
status: "ERROR"

I tried to Google solution to this but got no headway.

I checked the admin user account and see that there is dimension rescription on analytics categoryoptioncombo. After I removed it the error above disappear. What purpose does this restriction serve.

After I tried to access the data, I am not getting any response in the data visualization app.

No data available

The selected dimensions didn’t return any data. There may be no data, or you may not have access to it.

Hi @jetisco4u ,

Did you run analytics after entering the data? If not, then please go to Data Administrator → Analytics Tables and click on start export button.

The analytics job need to be run, for the data entered to be reflected in Visualisation applications.
You can also use scheduler app to automate this by adding Analytics job.


1 Like

@rithvik thanks to your suggestion the chart and data is now showing in data visualization app. But how can I set it to show the shortname of the organisationunit instead of the name?

Hi @jetisco4u ,

If you want this to be applicable to all the users in the system, then you need to set the " Property to display in analysis modules" as shortName in system settings.

If you want this behaviour only for the logged in user, you can click on the profile icon on right top corner → Settings and update " Property to display in analysis modules"

NOTE: Even other metadata items like DE, indicator etc will be displayed with short name