Curious case of login difficulty with Android App

Dear @dhis2-android team,

We are getting a curious case of login-difficulty with the latest playstore dhis2

For some installations (interestingly they all are lxc based dhis2 installations) we are not able to login to dhis2 through android app. But when we click Account Recovery option once and then go back and try it allow to login.

anybody facing this issue? we are not getting any errors, it just rejects the username password. Do you have some advice in further troubleshooting? I can share the URL and username/password for testing this.

Hi @jthomas

Are all these instances the same version? What version/s of DHIS2?

When testing are you using the same device?


1 Like
  • All versions are on 2.39.2 , but it was happening for 2.38.3 as well, so we upgraded to see the problem goes off, it didn’t

  • Yes all same device trying to connect different servers.

1 Like

Hi @jthomas,

that is a curious case, I can’t figure out how the Account Recovery option has an effect here. If you can provide us with some testing credentials, it would be great. Send me a DM with the credentials and I will take a look.


Thanks alot @vgarciabnz I DM you

Thanks @jthomas. I tried to connect and got this error:

There is a problem with the server certificates. Please, contact your administrator

Do you get the same error? If so, it means that the SSL configuration in the server side is missing an intermediate certificate. This issue can’t be noticed when accessing through a browser, but the Android app complaints about it and can’t connect. Check this post about this same issue, it can be usually solved by just adding the intermediate certificate in apache or nginx ( Trust anchor for certification path not found on tracker capture app dhis2).

Please let me know if you still can’t connect or if the error you get is different.


Thanks alot @vgarciabnz , I didn’t get this error for but i got this for another lower version when i tried.

Let me go through the post and try to fix and update here. Muchas gracias

1 Like

Updating the thread for future readers.

so we were able to solve this issue by adding one more entry like below in addition to SSLCertificateFile, SSLCertificateKeyFile

SSLCACertificateFile /etc/apache2/DigiCertCA.crt

Please note were using digicert SSL certificates

Thanks much @vgarciabnz for guiding me on this.