Could not save compulsory data elements v2.36

I got the message “Could not save compulsory data elements” when attempting to make a field compulsory for the existing data set “Clinical Monitoring Checklist” on the demo instance https://play.dhis2.org/2.36.0

However, when I created a new data set, I was able to define compulsory fields.

Any ideas why I cannot set compulsory fields on an existing data set?

Thanks.

Hi I would like to ask you if you think if this is because the 95 data elements in the “Clinical Monitoring Checklist” dataset could be the reason?

I will ask for support for you.

Thanks @Gassim! I tried adding just one of the 95 elements, ‘ANC 1st Visit’, to the compulsory list but got the message mentioned above.

One possible reason is that there is existing data with empty ‘ANC 1st Visit’ values, so I cannot make the field compulsory at this point. But I do not see any existing data for this dataset…

@dsurrao Please see the gif below are we doing the same steps because it’s working well for me! I selected the “Clinical Monitoring Checklist” dataset, edited compulsory elements, selected four, and clicked save - it worked!

CompulsoryElements

Maybe you have a browser issue? Would you try clearing the cache/history?

A nice way to keep your browsing activity separate so you can easily clear the browsing history, I would recommend trying the following if you are using Chrome:

Add a new profile

  1. On your computer, open Chrome.
  2. At the top right, click Profile image.
  3. Click Add.
  4. Please don’t sync for this one! (So that you can start “fresh”)
  5. Choose a name, photo and color scheme.
    (Google Chrome Help, )

This is an alternative way to clearing your browser history. For this profile, you can clear all of the browser history without affecting your other profile on Chrome. Please let me know if you need these settings for another browser!

It works now, both from the browser window I was previously using, and from a new one with a clean cache. So it probably was a browser cache issue as you mentioned, and in the former case the cached setting that was preventing an update expired, this is just my guess.

Thanks @Gassim !

1 Like

I’m so glad it worked! :smiley:

It might happen again and this is why I recommend watching this Jira issue: https://jira.dhis2.org/browse/DHIS2-11055