Core dump of the docker setup using the cli

#

# A fatal error has been detected by the Java Runtime Environment:

#

# Internal Error (safepoint.cpp:388), pid=1, tid=0x0000004041271700

# guarantee(PageArmed == 0) failed: invariant

#

# JRE version: OpenJDK Runtime Environment (8.0_312-b07) (build 1.8.0_312-b07)

# Java VM: OpenJDK 64-Bit Server VM (25.312-b07 mixed mode linux-amd64 compressed oops)

# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

#

# An error report file with more information is saved as:

# /tmp/hs_err_pid1.log

#
I’m just doing d2 cluster up 2.37.0 --db-version 2.37, from the getting started page on the developer portal. I have gotten this to run once, but haven’t been able to get it running since. I keep running into issues with the app being able to create the dhis.log file, which I think I solved. Now this issue:
I’m running on a Mac (pro, 14 inch, 2021, Apple M1 Pro chip).

# If you would like to submit a bug report, please visit:

# http://bugreport.java.com/bugreport/crash.jsp

#

qemu: uncaught target signal 6 (Aborted) - core dumped

Try:

See if it works when you using d2 cluster down --clean 2.37.0

If it’s not working, check out if these suggested solutions for Mac users work for you:

Thanks!

I tried the --clean (d2 cluster down 2.37.0 --db-version 2.37 --clean 2.37.0), and then doing the up:
d2 cluster up 2.37.0 --db-version 2.37

node:internal/bootstrap/switches/does_own_process_state:126
cachedCwd = rawMethods.cwd();
^

Error: ENOENT: no such file or directory, uv_cwd
at process.wrappedCwd [as cwd] (node:internal/bootstrap/switches/does_own_process_state:126:28)
at Yargs (/Users/jamesbarrows/.config/yarn/global/node_modules/@dhis2/cli-helpers-engine/node_modules/yargs/yargs.js:38:27)
at Argv (/Users/jamesbarrows/.config/yarn/global/node_modules/@dhis2/cli-helpers-engine/node_modules/yargs/index.js:12:16)
at Object. (/Users/jamesbarrows/.config/yarn/global/node_modules/@dhis2/cli-helpers-engine/node_modules/yargs/index.js:7:1)
at Module._compile (node:internal/modules/cjs/loader:1105:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1159:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18) {
errno: -2,
code: ‘ENOENT’,
syscall: ‘uv_cwd’
}

Once I reinstall my d2 cli, I’ll try the docker version from BAO.

1 Like