Combined program stages not Displaying data in Event Report App

We created tracker program where it has several stages to enter data.
it worked well.

But on the Event Report App we could not display data by combining the program stages.

Selected one Stage displayed data as shown below

Selected Multiple Stages not showing data

Please help

Welcome back to the community @Meky! :tada:

Please what version of dhis2 are you using? I can reproduce this on 2.38 but not 2.37 nor 2.36 so it might be a bug or a new feature. Let’s get input from one of the experts and see if you can create a Jira bug issue on jira.dhis2.org for this with steps to reproduce.

update: I tried again in version 2.38.0 and it worked! Please try to clear the cache and try again. If it doesn’t work please back to the community with the steps to reproduce this on any of the play.dhis2.org instances!

And if you can’t reproduce this on play, please see if there are any errors in the Console as well as the Network tabs in the Browser Developer Tools (F12)

Thanks! :+1:

Thank you @Gassim

I have already clear the caches but still i can not see the data in Event Report i have tried to view the console and i found this one

Thank you! @Meky, please try this task again in a clean/different/new browser and in incognito/private mode. It could still be the browser causing this issue.

I tried to reproduce this on play but couldn’t. Please what version are you using, are you able to reproduce this issue in play.dhis2.org?

Please try to get more info:


We need to get the Network request errors to see if there are details about the issue… and if the issue is generic, we might need to get the Catalina.out log

Thank you!

Thank you @Gassim for your reply i tried to run catalina.out and i found this error of scheduler app

@Gassim also i did what you to told me here the picture

Hi @Meky,
We need to continue digging to understand what the actual issue is and where it’s coming from.

Do you see any errors in the Catalina.out log when you run the analytics table export?

Thanks, sorry I should have also told you to click update again after you click Fetch/XHR [then if a red line appears, click on it and take a screenshot of the error please]

Thanks!

Hello @Gasssim
Thank you for your response. I tried to reproduce the state on the dhis2 demo app DHIS 2 Demo - Sierra Leone I found it also produces the same error.

Let me clearly explain

When you first create a STAGE or STAGES within a PROGRAM it works well, you can enter data and view them in an EVENT REPORT but after that when you add other STAGE or STAGES on the same PROGRAM you can enter data for specific ADDED STAGES but you can not see data in an EVENT REPORT for that SPECIFIC ADDED STAGE or combination with other STAGES within the same PROGRAM

Here are the screen shot below
Created new stage in Child programme with the name Test-stage

After entering the data via tracker Capture App it does not show data in Event Report App , I cleared the cache then running the Scheduler for pushing data to event report

Also the display on developer mode after clicking the update button

Hello @Gassim, I’m kindly waiting for your response

1 Like

Hi
Yes, I’m trying to reproduce the issue, thanks!

Sorry again does this only happen when you create a new stage? If so please did you try to run Analytics tables management export? (Go to Data Administration app → Analytics Tables → Start export)

[quote=“Gassim, post:3, topic:47211”]
2.38.0

[quote]

Thanks @Gassim
I ran the analytics table from the management app but it still produces errors.

Thank you @Meky! Core team developer @maikel was able to reproduce this issue in 2.37.6 but checked the 2.37dev and the issue no longer exists, so the fix will be available in the next releases for 2.37

And actually, @Meky for the 2.38 issue you faced. https://jira.dhis2.org/browse/DHIS2-13310. Thank you!

This is also considered a bug hunt so tagging you in the #copmonthly ; thanks!

Thank you, @Gassim.

I tried again to reproduce the flow on DHIS2 version 2.38 Demo-DHIS 2 Demo - Sierra Leone surprising It does not produce the errors. It displays all the data with the added stages in the Event Report App.

1 Like

Hello Community,

We were using DHIS2 2.37.6 which had some issues with Event Report, where it was not displaying data of the added New Stages and Elements.

On the way to solving this problem, we upgraded to version DHIS2 2.38.0. Again, we faced an error. where it couldn’t load the main page, as you can see in the picture below.

We tried to look at catalina.out in the Tomcat file, we found this error. which shows there is no PostgreSQL called pg_trgm and it requires to create it as a superuser

The error was solved by logging into PostgreSQL and creating a pg_trgm extension.

sudo -i -u postgres - login to postgres user

psql - Enter into postgres

\l - List all the database tables where you can see all databases

\c dhis2 - login to specific dhis2 database table

CREATE EXTENSION pg_trgm; - creating an extension called pg_trgm

CREATE EXTENSION btree_gin; - creating an extension called btree_gin

\q- quit from postgres

exit - Exit from the user

Then we resart Postgres and Tomcat

Then It works well, i think it might be useful for people who encounter an error similar to this

Thank you !

3 Likes

Hi there @Meky,

I was just about to make a post saying the same thing.

Are you on postgres 12 or 13? Our instances are on 12 and we experienced the same issue after upgrading to 2.38. I believe postgres 13 has these extensions installed by default, but I haven’t actually tested this yet.

Regardless, I think the installation documentation could do with updating as it recommends postgres 13, but in the installation instructions directs you to install 12, but makes no mention of pg_trgm or btree_gin.

Either way, relieving to see that this is an issue that others have faced and not a result of me borking something.

1 Like

Hello @HaydnJ,

Thank you for the clear description and explanation.
We are using PostgreSQL version 12.11. We will try to update PostgreSQL if possible to avoid other update errors.

1 Like