Changing tracked entity type


All created tracked entity type are missing (all tracked entity type) and thus we cannot register new records in tracker capture.
Can we create a new tracked entity type and assign it to the program?


Hi there @Sdn !
What do you mean that the tracked entity types are missing? Can you try restarting the server?


1 Like

@Sdn, thank you for the post! Please provide more details about the issue so that @Markus or anyone with insight can support you.

If restarting the server doesn’t work. I have some questions for you. Are the tracked entity types viewable to a superuser? Could this be a sharing issue? Are you able to access the API URL to view the TE types? [yourInstanceURL]/api/trackedEntityTypes?fields=trackedEntityType,displayName,publicAccess,access[read,write,data[read,write]] (play:,displayName,publicAccess,access[read,write,data[read,write]])

Additionally, please share what is the version of the DHIS2 instance that you are using, and check if you have any errors in the log as well as Network tab in your browser’s developer tools (F12 Console → Network)


Hello @Gassim and @Markus , I had similar issue and restarting the server fixed it. Can you PLEASE explain why restarting the server might have fixed it?

Hoping to learn.



Hi @Abumere_Ejakhegbe,

I’m glad that it helped you! From my side, I don’t have a technical explanation except that probably because when we restart, all apps close and when they start again the data is being loaded again which wasn’t loaded properly the first time maybe because of issues connecting to the server or various. :thinking: Would need lots of debugging to figure out what was exactly the issue but maybe it’s a general trick that solves a bunch of the issues that caused the problem above!

@Markus feel free to correct me or add… thanks!