Category options no longer showing up!

Good afternoon,

I wanted to reach out with two DHIS2 issues I am having (version 2.25) in the hopes that someone would be able to assist.

Under the “design data entry” form for one of my data sets, my form is no longer allowing me to see or assign category options (just data elements). Now, where category options used to be, it is labeled “[undefined].” As a note, this all started because I created an additional category option which I was having difficulty displaying/selection to link to my form, so I would appreciate any advice you have on this as well.

And then one final issue is related to sharing the dashboard with non-DHIS2 users (i.e. without people needing a login). I have been clicking the “share” button, checking the box for external user access, and then copying the web address for my Dashboard. However, when I send the web address, it is requiring that the person sign in. Any guidance on addressing this would be appreciated.

Best,

Heidi

Hi Heidi,
I have encountered this problem and one of the solutions is a tedious one. Have you by any chance assigned a new data element to this dataset? . If you have you will need to manually assign each data element to its category combo via the “wrench tool” - see attachment.

rgds

David

···

2017-07-11 22:42 GMT+03:00 Schroffel, Heidi hschroffel@care.org:

Good afternoon,

I wanted to reach out with two DHIS2 issues I am having (version 2.25) in the hopes that someone would be able to assist.

Under the “design data entry” form for one of my data sets, my form is no longer allowing me to see or assign category options (just data elements). Now, where category options used to be, it is labeled “[undefined].” As a note, this all started because I created an additional category option which I was having difficulty displaying/selection to link to my form, so I would appreciate any advice you have on this as well.

And then one final issue is related to sharing the dashboard with non-DHIS2 users (i.e. without people needing a login). I have been clicking the “share” button, checking the box for external user access, and then copying the web address for my Dashboard. However, when I send the web address, it is requiring that the person sign in. Any guidance on addressing this would be appreciated.

Best,

Heidi


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi David,

Thanks so much for the quick response.

In our case we did not add a new data element, but a new category option (which we linked to an existing category, which linked to an existing data set) and that ‘crashed’ the data set.

I don’t know if in this case the ‘wrench tool’ would still be helpful…in any case I can’t find it in our instance (version 2.25).

Any other thoughts would be very welcome.

Many thanks,

Heidi

···

Hi Heidi,

I have encountered this problem and one of the solutions is a tedious one. Have you by any chance assigned a new data element to this dataset? . If you have you will need to manually assign each data element to its category combo via the “wrench tool” - see attachment.

rgds

David

2017-07-11 22:42 GMT+03:00 Schroffel, Heidi hschroffel@care.org:

Good afternoon,

I wanted to reach out with two DHIS2 issues I am having (version 2.25) in the hopes that someone would be able to assist.

Under the “design data entry” form for one of my data sets, my form is no longer allowing me to see or assign category options (just data elements). Now, where category options used to be, it is labeled “[undefined].” As a note, this all started because I created an additional category option which I was having difficulty displaying/selection to link to my form, so I would appreciate any advice you have on this as well.

And then one final issue is related to sharing the dashboard with non-DHIS2 users (i.e. without people needing a login). I have been clicking the “share” button, checking the box for external user access, and then copying the web address for my Dashboard. However, when I send the web address, it is requiring that the person sign in. Any guidance on addressing this would be appreciated.

Best,

Heidi


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi all,

I met this case too when using version 2.25. And I already created report bug on Jira. you can follow on it to get new information when dev team reply to my report.

This is the link:

https://jira.dhis2.org/browse/DHIS2-1924

···

On Wed, Jul 12, 2017 at 10:21 PM, Schroffel, Heidi hschroffel@care.org wrote:

Hi David,

Thanks so much for the quick response.

In our case we did not add a new data element, but a new category option (which we linked to an existing category, which linked to an existing data set) and that ‘crashed’ the data set.

I don’t know if in this case the ‘wrench tool’ would still be helpful…in any case I can’t find it in our instance (version 2.25).

Any other thoughts would be very welcome.

Many thanks,

Heidi

From: David Muturi [mailto:dnmuturi@gmail.com]

Sent: Tuesday, July 11, 2017 3:58 PM

To: Schroffel, Heidi hschroffel@care.org

Cc: dhis2-users@lists.launchpad.net

Subject: Re: [Dhis2-users] Category options no longer showing up!

Hi Heidi,

I have encountered this problem and one of the solutions is a tedious one. Have you by any chance assigned a new data element to this dataset? . If you have you will need to manually assign each data element to its category combo via the “wrench tool” - see attachment.

rgds

David

2017-07-11 22:42 GMT+03:00 Schroffel, Heidi hschroffel@care.org:

Good afternoon,

I wanted to reach out with two DHIS2 issues I am having (version 2.25) in the hopes that someone would be able to assist.

Under the “design data entry” form for one of my data sets, my form is no longer allowing me to see or assign category options (just data elements). Now, where category options used to be, it is labeled “[undefined].” As a note, this all started because I created an additional category option which I was having difficulty displaying/selection to link to my form, so I would appreciate any advice you have on this as well.

And then one final issue is related to sharing the dashboard with non-DHIS2 users (i.e. without people needing a login). I have been clicking the “share” button, checking the box for external user access, and then copying the web address for my Dashboard. However, when I send the web address, it is requiring that the person sign in. Any guidance on addressing this would be appreciated.

Best,

Heidi


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Name: Nguyễn Trần Nghĩa.
Tel: 0903721500