Catalina: Organisation units cannot be empty

Dear Community
I am unable to add Data (Data Entry), I have added OUs, added Data Elements and Data Sets (i.e. followed manuals). But when I go to the Data Entry page I am unable to add any data.

On the left panel OUs can be clicked and it changes color to Orange as if it were selected.
Also OUs are also no being listed in Mobile App.
Going to /api/organisationUnits does list all OUs I have added.
Upon trying to use Apps for Data Entry, I am unable to list OUs.

Any ideas?

Salik Sadruddin Merani

1 Like


Did you assign the data set to an organisation?

Secondly did you share the data set with the group or users that will be entering the data?

This must be done for all users including the superusers



Yes I did assign the data to an organization, and just half an hour ago I solved it. I had to assign OU to the user. It is nowhere mentioned as a step and not in any tutorials anywhere.
I came across this thread which said to assign OU to a user. That did it.

This can be marked as solved.
I don’t know how to do that. Marked as Solution.

1 Like

Hello member
I would like to ask you a question
On which browser do you use DHIS2?
If you use Mozilla you have to change it to Google Chrome.

Please try after changing the browser it will go

I did not work on any browser (until the fix).
Tried Chrome, FF, Edge, Opera, Safari. All had the same error.