Can't login with no error messages

I have DHIS2 version 2.33.8 installed on a centos 7 server but I am unable to login with the default password admin/district. The funny thing is that it does not give any error message. I have tried several browsers, but I got the same result. Has anyone seen this before. Thanks for the support.

Hey @lordmaul, welcome to the community!

First, I would recommend you upgrade to the latest patch version of 2.34. Second, when you login, do you not see the ‘Invalid login information’ info? image So for example, if you open in “toggle device toolbar” (mobile/responsive mode) and then click login, are you taken to a new page such as the one in this image:

If it doesn’t take you to a new page then it would be helpful if you open the login page then open the Console (F12)/ Network tab and then try to login, see if there’s any error in the Network tab (please take a screenshot).

This info will be important to get further support! Thank you!

Good morning @Gassim, thanks for the response. The reason I am using 2.33.8 is that I want to restore a backup from another server once this one is working properly.

Usually when I try to login, it brings me back to the login page without any errors as show in the image below.

Once again, thanks for your support

This is the response on firefox.

1 Like

Okay, good luck making a backup but it seems you’ll have to login first! :grin:

This Console screenshot alone doesn’t show enough information, but I hope if the Network tab would show something?

  1. Open the login page
  2. Open the Console
  3. Click on the Network tab in the console
  4. Enter the login info and click on the sign in button
  5. Make a screenshot of the Network log

The other that I would like from you to test is to see if the page is redirected when you are using a mobile browser (like the image I posted above) click on the “toggle device toolbar” in the Console
image, please.

Thanks @Gassim for the response.
Here’s the screenshot from chrome showing the network tab

Also, here is the screenshot for when using the mobile view

Thanks for your support thus far.

1 Like

@lordmaul are there any errors in the server log?

1 Like

@austin not at all. I tailed it and this is the response

Warm regards.

Thank you for sharing the log! I first thought this would be a frontend issue, but @austin said it’s actually a question for the backend team, so we asked Morten Svanæs @netroms:

Not sure what’s going on here. Maybe he gets redirected back to the login page or something.
A couple of things to try:

  1. After login with user/pass, ask user to try enter another page url in manually and see if the user is able to access it.
  2. Try HTTP basic auth on an api url and see if that succeeds.

Thanks a lot @Gassim .
To answer the questions.

  1. After trying to login and I was brought back to the login page, I tried to manually access another page and was still brought back to the login page
  2. I tried using post man to send a post request and the response I got was the login page.

Thanks for your support

1 Like

You’re welcome!

@netroms Morten, says that this needs more debugging on the server, so is it possible to give him access? Or can you provide a copy it if you have good internet connection?

At this moment, he suggests downloading a fresh copy of the versions of the server you are running (2.33.8) from the DHIS2 binary archives, and try to use this new instance against your existing database. Preferably on a “fresh” machine.