Cant find tracker program in capture app after sync with web-instance


We are three master students from UiO currently working on configuring tracker programs in a training instance (DHIS 2). Once we have finished configuring the programs, we struggle with not finding the tracker programs in the DHIS capture android app.

We have tried to sync with MetaData Sync App and waited 2 days. The first attached picture is from our web-application and the second picture is the overview of available programs in android capture app. As you can see, the Test Houshold Program is available in the web version, but not in the android capture app.

We are using version on web and 2.8.2 on Android capture app

Can someone here help us with this?


the Android app takes into account data sharing settings to determine if the program must be downloaded or not. The label "Public view/edit) shown in program list in the app shows the metadata sharing settings. In order to know the data sharing settings you has to access the program, then go to “Access” and check the program access. You should see something like this:

In the picture, the program is public for metadata (anyone can see the definition of the program) but it is not public to actually create data for this program, so it won’t be downloaded by the Android app unless it is shared through a user or user group sharing setting.

Please check the settings of your program and modify them if needed. Let me know if it still doesn’t work.

1 Like

Hi @vgarciabnz and thanks for the reply earlier, below is an attached screen shot of one of our Tracker programs.

The setting for the preliminary is the same as well, but we can’t save the current settings as we get “Month not valid [1,4,7,10], was given 6” error. We’re not sure if this is the right approach or not. Awaiting your response.

Hi @Mohammed_Ali1 ,

Are you getting this error “Month not valid [1,4,7,10], was given 6” on the maintenance App when saving your sharing settings?

I am afraid I have not seen that error before, maybe someone from @tracker-products or @dhis2-platform can help.

Meanwhile, since you have some programs that are visible in the app, I would recommend to compare the configuration of your program with one that you can see. For example with special attention to the org unit assignment for data capture/entry.

You can also review the sharing settings of the Tracked entity type. And you can also reset the whole app and sync again from a clean instalation.

Mainly… if you can see some programs and not some others, it must be something on your configuration.

Let us know how it goes,

1 Like

Hi @Mohammed_Ali1

Would you kindly share the complete settings of the program? Let’s see if we can reproduce the issue on any of the instances?

Meanwhile, would you try again in your browser’s Guest mode as this could be caused by the browser cache: ( Browse Chrome as a guest - Computer - Google Chrome Help)

Thank you!

Hi @Gassim, i’m not sure which settings are you referring too, if there’s not an issue I can pm you the link to the program. Also I have tried the guest solution too, it doesn’t work.


Hi @Mohammed_Ali1

I mean the steps to reproduce the issue in any of the instances? If I can attempt to create a tracker program with the same configuration and save it, am I going to see the issue you mentioned “Month not valid [1,4,7,10], was given 6”?

Sure, I can have a look. Thanks!

@Mohammed_Ali1 please see the direct message!

Hi @Mohammed_Ali1

Thank you for the link to test. I see that the error happens when I try to save the Tracker Program as well as when I try to create a new Tracked Entity Attribute but the error is irrelevant because it’s simply taking the last error from the server (which means we need to have a look at the Catalina.out log).

Here are my initial suggestions:

  • I can’t reproduce the issue in the 2.39.3 instance, so would you please first update the version to 2.39.3 instead of

  • After the update please restart the server, clear server cache, and then check for any errors in the Catalina.out log

If the issue persists, please share the Catalina.out log (without authentication/sensitive into).


1 Like